Results 1 to 5 of 5

Thread: Dess bad?

  1. #1
    GamiGTX's Avatar
    Join Date
    Mar 2013
    Location
    Muskego, Wi
    Posts
    27
    +1
    1

    Dess bad?

    Running the ski hard, but running great. Just shut off like I pulled key off. Took key off put back on got a little movement on gauges. Then nothing again. Tried all three keys, nothing. Fuses fine. Any help before I try a new dess post? Thanks


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    How about your battery???

  3. #3
    GamiGTX's Avatar
    Join Date
    Mar 2013
    Location
    Muskego, Wi
    Posts
    27
    +1
    1
    Connections are tight. I have had no problems with it. It would just shut off like that? I wouldn't think so. But I will put a test on tomorrow.

  4. #4
    GamiGTX's Avatar
    Join Date
    Mar 2013
    Location
    Muskego, Wi
    Posts
    27
    +1
    1
    Battery fine. Not the dess post. Corrosion around the fuse box areas was the problem.

  5. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,514
    +1
    1,258
    make sure the triple lipped gasket is set correctly, a little grease doesn't hurt. make sure the cover is snapped in all around. Even then if you flip it, it's going to get wet in there....;-(

    "it's always the electric box on a late 90's g series Seadoo." snarled the wooly old captain as he spilled his grog on the floor

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bad DESS post or MPEM?
    By Lord Helmet in forum 2-Stroke Performance
    Replies: 4
    Last Post: 08-24-2014, 07:45 PM
  2. Will bad dess post do this?!
    By RJG in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-21-2012, 02:13 PM
  3. Bad DESS post symptoms?
    By Vern in forum 4-Tec Performance
    Replies: 25
    Last Post: 03-13-2010, 10:59 PM
  4. How bad is you RXP ? ? ? ? ?
    By Jrsrxp in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 06-07-2005, 07:50 PM
  5. BAD NEWS... 05 RXT GPS #'s
    By Shibby1485 in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-22-2005, 07:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •