Hello to all - So i've had two issues and I'm thinking they could somehow be related...looking for input /advice.

1st major issue - No start on Starboard motor. Tested switch by switching to Port motor and fired. If I cross the Starter Relay/Solenoid post fires right up and runs fine....so, I bought a new Starter Relay, installed and it fires right up. tried if four- five time and worked well. I sat at the dock cleaning it up a bit and when I went to take off..no start again? It does not click or anything. I also checked the 2 fuses attached to the relay and they look fine with absolutely no corrosion. BTW the is and always has been in Fresh water.

I'm thinking I either missed a fuse or I have a ground issue...any thoughts?

2nd issue - Battery light of my Port engine flickers under full throttle. I probably wouldn't have even noticed if I didn't take it out on the 4th of July. I had LED lights and a Bazooka Tube hooked up and I disconnected and it still does it...actually it did it worse with those hooked up?

I don't know if they are related but I figured I'd mention it.....Thanks for any help on this!!