Results 1 to 10 of 10
  1. #1

    1995 seadoo xp hard start?

    I have a 1995 xp 720 that takes like 10 minutes of cranking to start?I have to hold the throtle pinned and then starts a little then slowly with in a couple of minutes takes off full speed and will ride perfect untill shut off again?even if shut off for a minute when restarted does the same thing,it has all new lines,I blew out the vent,tried a primer bulb which didnt seem to help(seemed to be hard alot as if getting air)also by the time it does start I get alot of oil comeing out of the exaust.The previous owner said he had the carbs rebuilt.Any ideas?dont think the carb is plugged or it wouldnt go full speed with no bogging or rough running,it actually runs smoother than any other I have had,also the oil tank is still hooked up but I am useing premix as the previous owner didnt think the oil pump worked.


  2. #2

    Join Date
    Aug 2014
    Location
    Clovis CA
    Posts
    13
    First thing I'd do is test too see if the oil pump is working, either take it off and bench test it properly or do a quick and dirty test by reaching down while the ski is idling and turning the cable operated control valve full open, if its working properly it should smoke alot more. If the pump is working then I'd ditch the premix and go from there.

    Also if you have the stock grey tempo fuel lines, get rid of them and clean your entire fuel system out.

  3. #3
    ok,thanks will try that test,and the fuel lines are all new black ones with the crimped on clamps.

  4. #4

    Join Date
    Jul 2012
    Location
    DFW TX
    Posts
    175
    +1
    22
    Also check your compression.

  5. #5
    I think compression is good as it really gets up to speed,seems much faster than my last xp,has a blue spark both cylinders but the plugs get wet befor it will start?

  6. #6
    I think it has to much oil

  7. #7
    PWC Addict lilman573's Avatar
    Join Date
    Feb 2010
    Location
    Central NJ
    Posts
    2,947
    +1
    207
    Either that or your seats are leaking by in the carbs.... Sounds like its flooding. Were the carbs rebuilt?

  8. #8
    previous owner said they were rebuilt,I put 50 to 1 oil and a little extra plus the oil injection apears to be working,if thats not the problem will tear down thw carbs,thanks for all of the replies.

  9. #9

    Join Date
    Aug 2014
    Location
    Clovis CA
    Posts
    13
    You mentioned the plugs are wet, are they wet with fuel or oil?

    With 50:1 in the tank plus the around 40:1 the oil injection system puts in at full throttle never mind the little extra you put in as well, you're basically asking the ski to run on close to a 22:1 mix.

  10. #10

    Join Date
    Jul 2012
    Location
    DFW TX
    Posts
    175
    +1
    22
    Quote Originally Posted by patdufo View Post
    previous owner said they were rebuilt,I put 50 to 1 oil and a little extra plus the oil injection apears to be working,if thats not the problem will tear down thw carbs,thanks for all of the replies.
    Update... fixed now ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 seadoo xp hard start
    By 7Springs in forum 2-Stroke Performance
    Replies: 5
    Last Post: 07-14-2013, 04:33 PM
  2. 1995 seadoo xp starting issue
    By Schaffer5103 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-27-2013, 09:29 PM
  3. 1995 Seadoo XP 785
    By MPower in forum 2-Stroke Performance
    Replies: 62
    Last Post: 04-14-2012, 04:06 AM
  4. 1995 seadoo xp 800
    By gorilla03 in forum Sea Doo 4Tec Skis
    Replies: 22
    Last Post: 12-20-2008, 08:12 PM
  5. 96 xp hard start in water.
    By 99wrangler in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-15-2008, 06:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •