Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    05 speedster 150 engine question

    I have a 05 speedster thats having some issues right now. The way my friend described , was the ski will start up just fine and run just fine. But once he shuts the motor off it wont restart. The plugs get wet and the engine refuse to turn over. The only way to get it to start, is if If the plugs get removed, and cleaned off. Once that happens, itll start right back up again immediately, and drive just fine.

    I have a few ideas and have not looked at the ski yet, but was wanting to find a few things i should check. Ski came back from Riva 3 months ago and was checked out perfectly.

    I appreciate any suggestions.


  2. #2
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Location
    Bowling Green, KY
    Posts
    1,376
    +1
    162
    Find out what this thing really is... they didn't make a 150... might be a 155 or a 130, but based on the unrecognized "150" it could be anything. Speedster is a boat, but you are calling it a "ski" which is it? LOL It could be SCIC and have a leaking intercooler which is what it sounds like, or it could have a bad head gasket, or it could be a bad exhaust manifold... but for sure there is not enough information in your post for someone to make an intelligent guess... What i do know is that if you continue to run it this way you are going to destroy the motor... it's a hydrolock just about to happen. Also, if there is water in the cylinders there is water in the oil, water in the oil is bad...

  3. #3

    Join Date
    Feb 2012
    Posts
    663
    +1
    45
    speedster 150=15 foot boat.
    i think it has a 215HP... .

  4. #4
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Location
    Bowling Green, KY
    Posts
    1,376
    +1
    162
    Ahh... leaky intercooler is the #1 suspect. Pressure test the interecooler.

  5. #5

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    It's going to be the intercooler (215hp) or the exhaust manifold. It's about a 50/50 on witch one it is. I have had both a few times on different things. Most of the time for me if it was a leaking intercooler it just run poor but would alway restart. On the exhaust manifold didn't notice to much lost on performance but most of the time would not restart.

  6. #6
    Thanks for the replys guys.

    Are there o ring or seals that go bad or something specific I should look for on the manifold. Or will a standard exhaust gasket fix this issue (if its the problem)...

    Ill test the inter-cooler as well.

    Sorry for referring to it as a ski..

  7. #7

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Quote Originally Posted by kwtony View Post
    Thanks for the replys guys.

    Are there o ring or seals that go bad or something specific I should look for on the manifold. Or will a standard exhaust gasket fix this issue (if its the problem)...

    Ill test the inter-cooler as well.

    Sorry for referring to it as a ski..
    No gasket on the manifold. The casting just gets eaten up. It will be close to the Jpipe were the casting brakes down. You can check it with out taking it off. There is 3 water jacket on it 3/4 in front and the two 1/2" at the other end. Block of two of them and just blow in the other one. If it's bad you will be able to blow air in.

  8. #8
    Ahh fantastic. I know exactly what you speak of. I will test the BOAT very soon and will post the results as soon as i Know. Thanks for the info, ill try and take photos of anything I have questions on.


    My friend tells me it drives just fine and runs beautifully, but wont restart... I assume the entire manifold would need to be replaced.?

    You wouldn't happen to have the manual to this sk-boat by chance?

  9. #9

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Quote Originally Posted by kwtony View Post
    Ahh fantastic. I know exactly what you speak of. I will test the BOAT very soon and will post the results as soon as i Know. Thanks for the info, ill try and take photos of anything I have questions on.


    My friend tells me it drives just fine and runs beautifully, but wont restart... I assume the entire manifold would need to be replaced.?

    You wouldn't happen to have the manual to this sk-boat by chance?
    Yes if the manifold is leaking you will have to buy a new one. Any year will work they are all the same. The 08 and new has a better casting.

  10. #10
    Thank you, im going to look at the boat in a few.


    Ill be doing my usual inspections on the motor, controls, electrical connections and what not, but is there anything specific to this boat that I should look for , special things i wouldn't normally see on a good once over. Thank you, appreciate the help so far.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 Speedster 150 Stereo question
    By brdouglas in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 09-01-2016, 01:26 PM
  2. FS - Parts Brand new oem seadoo sportster/ speedster 150 engine hatch cable & reverse cable
    By H20mxracer223 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 11-10-2015, 01:24 PM
  3. 215 hp Speedster 150 Buying Questions
    By Corey R. in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 09-25-2010, 02:41 PM
  4. 2007 Speedster 150 Wake Tower question
    By Riderman in forum Sea Doo Sport Boats
    Replies: 9
    Last Post: 12-23-2008, 09:46 PM
  5. New 2007 150 speedster owner newbie questions
    By fugazi in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 09-15-2007, 09:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •