Page 1 of 24 1 2 3 11 ... LastLast
Results 1 to 10 of 239
  1. #1
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407

    Post Your Technical Information Requests

    Ues this section to post your requests! We will try to post the info in the tech section. There will also be some changes to the tech section in the near future. As we try to organize and make the section more searchable. Please add your input as this is your forum and we want to help. We also would like some input as to what you would like to see in the tech section as well as dislikes.

    Thanks, The Polaris Staff!!!


  2. #2
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Location
    Roanoke, Va
    Posts
    3,083
    I remember some time ago some info on using a hobby eletric motor being used for the trim motor. I would like to see that info added if anyone still has that info.

    Thanks,
    R

  3. #3

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    lets find out what kind of motors they are useing in the valve motor on the 785's i have three of them with bad motors .

  4. #4

    Join Date
    Apr 2007
    Location
    Barrie, Ontario
    Posts
    8

    95 SL 750

    Is anybody aware of an online manual for this boat? I'm working on one, and am ok rebuilding the motor, but the plumbing and fuel routing are slipping my mind!!! What are the tourque specs for the cylinders and the heads?
    Thanks
    for your help
    Later
    Chad Mooney

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Hi Chad, WELCOME to the Green Hulk Forums!!
    I see you have your answers already.

  6. #6

    2004 virage 1 polaris

    when i start it it runs fine i get on the water and in about 10 minutes it dies, like it is a electrical problem. it acts like the battery is dead. the next day it does the same thing. i replaced 2 batteries. i cant figure it out. when it happens and i pust the start button nothing happens

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Chad, You should post this in the General Q/A section as this is for document and technical data.
    But check your charging system and WELCOME to the Green Hulk Forums!

  8. #8

    Polaris SL 780 oil pump question

    Got a SL 780 recently which smokes a lot. Wanted to check the oil pump adjustment and the linkage length is ok. What bothers me is that the Clymer manual states that if the linkage comes out by accident, the pump will go to max, which is anti-clockwise viewed from starboard side due to the spring.

    The linkage however rotates the pump CLOCKWISE as the throttle opens, so actually giving less oil ? Can anyone help clear the confusion please ? What is the correct position for the links to the pumps shaft and why is there no idle alignment mark ?

    Thanks !
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Oil Pump.jpg 
Views:	882 
Size:	269.6 KB 
ID:	23745  

  9. #9
    Jug Inspector
    Join Date
    Aug 2006
    Location
    Chicago Burbs
    Posts
    552
    Any chance anyone has some CDI curve charts for the 650, 750, 780, 785, and the rev limit on them?

    Thanks,

    Bryan

  10. #10
    Jug Inspector
    Join Date
    Aug 2006
    Location
    Chicago Burbs
    Posts
    552
    Any luck?

Page 1 of 24 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Post Your Technical Information Here
    By ph2ocraft in forum Polaris Tech Tips and Info
    Replies: 51
    Last Post: 04-30-2013, 06:03 AM
  2. Post Your Technical Information Here "NOT A QUESTION SECTION"
    By ph2ocraft in forum Kawasaki Tech Tips and Info
    Replies: 4
    Last Post: 06-30-2007, 06:27 AM
  3. Post your RIVA RXP Stage 1 numbers
    By RXP-REX in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-27-2006, 10:54 AM
  4. Boost readings, please post yours
    By Vern in forum 4-Tec Performance
    Replies: 34
    Last Post: 01-18-2006, 07:19 PM
  5. Post your favorite links.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-11-2005, 04:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •