Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1
    jajardas's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    535
    +1
    19

    1999 SLX Stator??

    I purchased a 1999 SLX starts up nicely on trailer but I have not put it into the water yet because the previous owner said it still has issues and i do not want to melt a piston or throw a rod.
    All work was done by a his mechanic at a dealer in town.
    List of repair done??
    Carbs rebuilt adjusted to spec, New CDI from a updated ignition kit. (picture of new stator attached)
    It was supposed to have an updated stator in it already.

    He said it will run wide open but you have to feather the throttle to get it there. His mechanic said it has bad base gaskets now.
    Compression is 119 across the board. I pressured tested the motor and it held 10 lbs of pressure for over a hour. I checked the crank index with the pencil method and it is spot on.

    My question is how can I tell if it really has a new stator in it? Was it a OHM test posted somewhere that it would be a different value. I may have answered my own question and will search. Is there anything else I can see or be able to tell by?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	newstator.jpg 
Views:	45 
Size:	85.3 KB 
ID:	339858   Click image for larger version. 

Name:	newstatorinvoice.jpg 
Views:	46 
Size:	37.5 KB 
ID:	339859  


  2. #2
    jajardas's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    535
    +1
    19
    Also brand new battery

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    The updated CDI will not run with an original 900 or 1050 engine 1996-1999 stator. At all. If the CDI is indeed the Gen III version then the stator must also be Gen III.

    When the engine was pressure tested was the water jacket also pressurized or open to the atmosphere?

  4. #4
    jajardas's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    535
    +1
    19
    Thanks for the quick reply. I removed exhaust the pipe with the 4-1/2 bolts and capped the large 2 inch hole in the exhaust manifold.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by jajardas View Post
    ... I removed exhaust the pipe with the 4-1/2 bolts and capped the large 2 inch hole in the exhaust manifold.
    So the engine water jacket was not pressurized, correct?

  6. #6
    jajardas's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    535
    +1
    19
    Keith,

    I plug number 17 here with the red circle.
    JOE
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	number 17.jpg 
Views:	41 
Size:	50.3 KB 
ID:	339860  

  7. #7
    jajardas's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    535
    +1
    19
    It was still attach and held pressure.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by jajardas View Post
    Keith,

    I plug number 17 here with the red circle.
    JOE
    And what else was capped?

    Number 19, for example?

  9. #9
    jajardas's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    535
    +1
    19
    I removed the hose from 19 and left it open. The only other thing I capped was the intake for each of the three carbs.

  10. #10
    jajardas's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    535
    +1
    19
    My last post was wrong I did cap number 19. Just hit me as I was driving home from work. So it held pressure for over a hour.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 1999 SLX 1050 Polaris Stainless Steel Stator and Impeller
    By sea~smith in forum Polaris Classifieds
    Replies: 7
    Last Post: 06-24-2015, 10:20 AM
  2. WTB - Parts need stator / magneto for 1999 slx 1050 (update kit would be ideal)
    By sea~smith in forum Polaris Classifieds
    Replies: 10
    Last Post: 03-03-2015, 01:08 AM
  3. stator 1999 slx 1050/what years work
    By sandonut in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-27-2014, 09:01 PM
  4. Replies: 1
    Last Post: 07-01-2013, 09:38 AM
  5. 01 slx stator testing
    By 785 lugs in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 09-25-2006, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •