Results 1 to 5 of 5
  1. #1

    Join Date
    Jan 2006
    Location
    Patterson La
    Posts
    369
    +1
    54

    15F hard start / Rough idle

    My 08 15F is hard to start sometimes, and it will idle rough until I touch the gas. After I rev it a little, it will run fine. I was thinking it was the temp sensor, but it will do this when it is hot or cold. I changed the plugs, and it still does it. I've never changed the fuel pump. Any ideas?


    Thanks


  2. #2
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1
    Bought a 2010 stx15f with 26 hs and was like a year and a half stored and have that same problem! Compression is good on all 4 cilinders changed sparks to ngk iridium and the problem still goes. Cleaned the injectors and the sky does it a lot less. Try sending them to a shop so they clean them. Also i did not changed the fuel filter cause the dealer hasnt got here and never changer one either.

  3. #3
    I've had this same problem on some other skis like the RXPX and 310X. Even when they were brand new they would never start on the first crank IN the water. Out of the water it was the first crank. As each trip went by the starting took longer and longer in the water. Has it got something to do with the load the impeller puts on the engine when in the water? I always try to empty the waterbox after each ride. The rough idle is another issue, never had that problem

  4. #4

    Join Date
    Jan 2006
    Location
    Patterson La
    Posts
    369
    +1
    54
    I'm going to change the fuel pump. I don't know if that's it or not, but its the original fuel pump. What's throwing me off is that it stops idling rough as soon as I touch the throttle. then it runs fine until I shut it off.

  5. #5
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    Go through the guide in my signature.

    Sean

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: 09-07-2013, 12:46 PM
  2. Hard start rough running
    By Itowpolarismatrix in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-21-2013, 09:31 PM
  3. SLTX - hard start, low idle, 5200 rpm max -HELP!
    By ralt33 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 06-20-2010, 09:35 PM
  4. New info SLTX - hard start, low idle, 5200 rpm max -HELP!
    By ralt33 in forum Polaris Open Discussion
    Replies: 18
    Last Post: 04-24-2010, 11:17 AM
  5. 96 SLX780 Rough Idle, Hard Start, and Miss
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 23
    Last Post: 02-27-2008, 06:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •