Results 1 to 5 of 5
  1. #1

    2004 RXP 215 fuel pump inop

    Hey everyone. I'm pretty new on here, and to the Jet ski stuff in general. I have a 2004 RXP 215 that is having problems all of a sudden. This past weekend, I was riding it, and came to an idle zone and shut it off so I could talk to my friends and my parents on the boat next to me. It wouldn't start back after that. It will crank, but won't start. It would fire and die, fire and die, then it wouldn't even do that. We trailered it until we got home Monday. The fuel pressure test port didn't have any pressure on it, even while cranking. So automatically, being the mechanic I am, assumed it was the fuel pump, or possible the DESS system that shut it down. I check all my fuses, and they're all good. They all have continuity. I pulled the plug off the fuel pump assembly, and it has Battery Voltage when the key is on for a second, just like it should. I checked the two outside pins, which lead to the pump (the two inner ones lead to the plug on the fuel level float). So I ordered a new pump motor from Bosch. Got it in today, and it STILL doesn't work. It has 12 volts at the pump plug as well, so I'm a little confused. The new pump won't work, the old pump doesn't work, but yet I have power at the plugs for it. I pulled the spark plug out of a cylinder and it is firing the plug, so that eliminates the ignition system. Anyone have any ideas as to what could be causing this? I traced my wires down, and couldn't find anything cut, loose, or anything. So I'm stumped. When I put my meter across the two pins for the pump, with the pump not connected, it has battery voltage, but when the pump is connected, it doesn't. I really hope it isn't the MPEM or the ECU.


  2. #2

    Join Date
    May 2012
    Location
    California
    Posts
    1,553
    +1
    130
    have you jumped power to the pump to verify it is inop? I have one from a 2004 rxp I'm parting out if interested.

  3. #3
    For right now, it's working for some reason. I think it may have had a bad connection into the MPEM or ECU. Would you happen to have the spring from the fuel pump assembly? I lost mine. Lol and I don't want to have to buy the whole assembly.

  4. #4

    Join Date
    May 2012
    Location
    California
    Posts
    1,553
    +1
    130
    Quote Originally Posted by highfly24 View Post
    For right now, it's working for some reason. I think it may have had a bad connection into the MPEM or ECU. Would you happen to have the spring from the fuel pump assembly? I lost mine. Lol and I don't want to have to buy the whole assembly.
    there is no way I would dismantle a perfectly good working fuel pump to sell a spring unless you want to pay the same price as the pump.

  5. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    just because it works is not good
    when is acts up again (it will) you can damage your motor
    running a very old pump will bite you in the ass
    the pump is turned on by a ground from the ecu B29

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can an 07 Fuel Pump be replaced by an 08 RXP-X fuel pump?
    By TheElite0ne in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-30-2010, 01:44 PM
  2. FS Seadoo 215 Fuel Pump
    By shooter98xpl in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-22-2010, 05:35 PM
  3. FS: Sea Doo RXP/RXT Fuel Pump Assembly
    By neversatisfiedmotorsports in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-16-2009, 04:58 PM
  4. 2004 RXP 215 S/C *Blow Motor* Cheap!
    By greeksupra in forum Sea Doo 4Tec Skis
    Replies: 5
    Last Post: 08-07-2009, 04:36 PM
  5. 2004 rxp 215
    By gsxr800 in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-28-2009, 12:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •