Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Aug 2014
    Location
    Palm Harbor, FL
    Posts
    35

    2014 FX SVHO Multi Display flashing - all of it

    Hi,
    Newbie here, ski has around 6 hours on it and this has happened a few times now. After running and shutting off, hanging out and then getting back on ski the entire multi function display is flashing. Not merely check engine or oil warning but all the lights and the LCD mini display is all flashing too. Shut her off, hang out more, it usually goes away.

    Any pointers please?

    Thanks, Ant


  2. #2
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,206
    +1
    458
    Try disconnecting the battery for a couple minutes.

  3. #3

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    check both battery connections to be sure they are clean and tight, Tommy Jordan

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Take it back to dealer

  5. #5

    Join Date
    Aug 2014
    Location
    Palm Harbor, FL
    Posts
    35
    Quote Originally Posted by JoeyDFZS View Post
    Take it back to dealer
    Thanks for the suggestions, I'll try the battery which I assume is ECU reset? Although back to dealer she goes if that doesn't do anything.

    Cheers

  6. #6
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    Have one doing the same thing 25 hours. Working on figuring out what is wrong, hopefully get to it this week. Will let you know.

  7. #7
    Hmm Does the manual say anything about this?

  8. #8

    Join Date
    Aug 2014
    Location
    Palm Harbor, FL
    Posts
    35
    Quote Originally Posted by crashhard View Post
    Have one doing the same thing 25 hours. Working on figuring out what is wrong, hopefully get to it this week. Will let you know.
    Thanks would love to hear if you find anything.

  9. #9

    Join Date
    Aug 2014
    Location
    Palm Harbor, FL
    Posts
    35
    Quote Originally Posted by Bryan Miller View Post
    Hmm Does the manual say anything about this?
    Not that I have seen no. It mentions all the separate warning indicators and beeps but not what the complete display going bananas means.

  10. #10
    This happen to my friends with 20minutes on it, just reset the battery and it was fine

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2014 FX SVHO - Loss of power.
    By rememberthehuman in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-24-2016, 09:09 PM
  2. Need help with install of Lucky cone on 2014 fx svho
    By macattack in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-17-2016, 12:36 AM
  3. Replacing Ecu on 2014 fx svho with flashed one do I need to switch cluster too ??????
    By macattack in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 12-29-2015, 11:55 AM
  4. Replies: 0
    Last Post: 12-29-2015, 11:02 AM
  5. Stunned owner of a new 2014 FX SVHO
    By newbietoyamaha in forum Yamaha Open Discussion
    Replies: 20
    Last Post: 05-19-2015, 02:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •