Results 1 to 8 of 8
  1. #1

    1999 kawasaki 1100 stx engine bay flooding ???? HELP

    I've had my ski a good month and a bit and everything was fine running good until Sunday. Got the ski in the water everything was fine and was towing my inflatable no problem, took it out for a little spin for about 15mins and it felt unstable, went back to ramp and the engine bay was full off water so much to the bottom of the battery, took ski out the water drained it and checked for hull damage none and sat it back in water to check for leaks no leaks, then sat with seat off running idle looking for possible hose crack or spilt nothing. Put seat back on and went out for 10mins this time was really unstable after 10 mins. Went back to ramp was at the same level drained and checked all hoses again nothing. I haven't tried running at speed with seat off which is next option as it was getting dark but does anyone have any ideas as why it is letting in so much water in such a short space of time any help appreciated. P.S not very good with the whole mechanics on the jetski so in simple form prefered if you could please


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,008
    +1
    283
    The most common source for a leak is the bearing holder for the driveshaft. Since you didn't see it leaking there, and since it seemed to leak while running, I would suspect a hose has come loose or is damaged, or something like that.

  3. #3
    I have checked all hoses whilst in water and the hose connected couldnt see anything and double checked all connections.. would the bearing holder leak if ski was just sitting in water or would u have to go at speed for this to leak? Thanks

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,008
    +1
    283
    I don't know. The ones I've seen leaking leaked while sitting still. They probably leaked while running, but I didn't run them after I discovered the leak.

  5. #5
    Ok so I filled he hull up to the bottom of the driveshaft and right enough the water is leaking through. what is the procedure for fixing this problem or would I have to buy new parts thanks

  6. #6
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,008
    +1
    283
    Lift the engine, slide the driveshaft forward, replace the bearing holder. You can buy aftermarket holders that are self-sealing, or seal the original type seal with 3M 4200 sealant. Slide the driveshaft back in, re-install the engine, then tighten the bearing holder screws.

  7. #7
    Would this let in alot of water ? Or could it be that the aluminium drive shaft tunnel has sperated from hull or would I just need to check that when I have removed bearing holder. And would I need to buy a new seal or use exisiting one ? Thanks

  8. #8
    Could be either causing the leak. Listen to steve he is giving you very good advice.

    If the bearing holder is going bad and leaking from my experience it will leak worse while the engine is running.

    Here is what you do, put the ski in the water on the trailer strapped down. With the seat popped watch the four bolt holes on the drive shaft coupler. Also look where the aluminum peice is glued to the hull for leaks. If there is a leak you will find it at this point. If you need to start the engine it is safe to do so.

    I have had leaks from the drive shaft coupler and the thru hull. Both of those spots are the most common. Either way engine has to be pulled. Do a search there is plenty of info on this, these two spots are the most common.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Kawasaki 1100 STX - Dead Cylinder - need help
    By Mbrundige in forum Kawasaki PWC Performance (2-stroke)
    Replies: 24
    Last Post: 04-05-2017, 10:58 AM
  2. 1999 Kawasaki 900 stx PLEASE HELP
    By Bryan in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 06-07-2013, 07:58 PM
  3. need Shuttle Craft rails for my 1999 Kawasaki 1100 STX
    By Jonathan Platt in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-25-2012, 08:18 AM
  4. Kawasaki 1100 stx engine rebuild quesitons?
    By sphinx in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 06-20-2011, 04:29 PM
  5. Help Bought 03 Kawasaki 1100 stx di
    By kkhealer in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-10-2010, 05:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •