Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    I have some oily water come out of my rxp-x255

    After getting back from a ride today and after taking the drain plugs out I seen abet of oily water coming out I looked in side the ski but am not seeing anything has anyone had this happen and what does it mean


  2. #2
    May be coming from the PTO boot and bearing assembly where the driveshaft goes i to the PTO. See if you can feel oil at the bottom of the boot.

  3. #3
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    I'm guessing PTO as well. Happened to me before. Sucks.

  4. #4
    So if it is. Do the engine have to come out, because it was just out and a new seal put in

  5. #5
    PWC Addict lilman573's Avatar
    Join Date
    Feb 2010
    Location
    Central NJ
    Posts
    2,946
    +1
    207
    A new PTO bearing was put on? Were hose clamps used or the stock oiteker clamps??

  6. #6
    I don't think so, only a new gasket we were looking to see if the thrust washer was in there.

  7. #7
    This is what I found, it seemed like there was more water then oil mix , when i was ringing out the rag, I wonder if it came from the catch can , I did lose some the other day and my filter was do to be changed. Anyway I clean most of it, do you guys think it would be alright to ride it and see if it happens again
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	41 
Size:	224.3 KB 
ID:	340373  

  8. #8

  9. #9
    PWC Addict lilman573's Avatar
    Join Date
    Feb 2010
    Location
    Central NJ
    Posts
    2,946
    +1
    207
    This is what you are looking for when they say pto bearing. Mine was clamped and slipped off. It was leaking like a siv.
    Click image for larger version. 

Name:	uploadfromtaptalk1409705669489.jpg 
Views:	34 
Size:	73.7 KB 
ID:	340381

  10. #10
    I don't have that. And my oil level seems to be saying good tiny bet gone over a period of riding

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pulled some mud into vx cruiser no water coming out of the top? help please
    By JoezCrown in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 09-08-2011, 08:28 PM
  2. 08 VX Deluxe - half speed, no water coming out of side exhaust port
    By Lee G in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 06-28-2011, 12:47 PM
  3. Water coming out of exhaust
    By Texan78 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 14
    Last Post: 06-07-2011, 09:59 AM
  4. FX SHO no water coming out of cooling spouts?
    By SHOBOATIN in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 04-17-2011, 01:32 PM
  5. water coming out of the spark plug holes
    By big mark in forum Yamaha Open Discussion
    Replies: 22
    Last Post: 06-26-2007, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •