Results 1 to 5 of 5
  1. #1
    silver93t's Avatar
    Join Date
    Jun 2012
    Location
    NJ
    Posts
    1,064
    +1
    49

    13 FZS Overheat light?

    I finally got the ski back from the body shop after an accident I had early in the summer. First time out I rode for about 20 minutes. Bay was way too rough so I cut it short. The next day I rode for maybe an hour. I sucked up some seaweed and got bad cavitation until I cleared it. Then did maybe another 20 minutes of easy riding. I ended up idling in front of the ramp for about 5 minutes because some jackass blocked the entire 2 space ramp and was taking forever to load his boat. At this time I got the buzzer and a temperature light on the cluster. Water was coming out of both pissers and the motor did not feel excessively hot. I hit the reset button, shut the ski off, then restarted. Ended up running the ski for maybe another 3-5 minutes before the guy cleared the ramp and the light did not come back. Once loaded on the trailer I looked for any blockage in the pump area but didn't see anything. I ran it on the hose later for a few minutes and the light didn't come back either. Should I look into this further or could this just be an electrical fluke? I did rinse off the motor and bilge to clean some of the dust from the body shop. Maybe got a temp sensor wet?


  2. #2
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,501
    +1
    619
    I wouldn't worry about it,at the time of the suck up of weeds you were probably close to overheating,even though you seem to clear the pump clog the idling at the ramp hasn't circulated the water quickly enough thru the water jackets to extract the heat so the sensor for a moment read overheat..
    Take it out next time and just cruise around at different RPMs staying near shore,if everything looks normal your good to go

  3. +1 by:


  4. #3
    silver93t's Avatar
    Join Date
    Jun 2012
    Location
    NJ
    Posts
    1,064
    +1
    49
    Ran it on the hose for a while and got no light. Then rode the ski for about 3 hours and nothing. Weird.

  5. #4
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,579
    +1
    87
    Buy the new FZS........

  6. #5
    silver93t's Avatar
    Join Date
    Jun 2012
    Location
    NJ
    Posts
    1,064
    +1
    49
    Why? I'm still faster than you, even with 36 double d's in tow

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 13 FZS Water in motor
    By silver93t in forum Yamaha PWC Performance (4-stroke)
    Replies: 19
    Last Post: 07-06-2014, 11:29 AM
  2. 13' FZS Intake grate ?
    By Alexslow1k in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-25-2014, 04:56 PM
  3. Nav for '13 FZS
    By dshanker in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 05-10-2014, 06:26 PM
  4. Summerizing 13' FZS
    By GASKING in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 05-04-2014, 10:16 PM
  5. New Here 13' FZS
    By Alexslow1k in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 04-14-2014, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •