Results 1 to 5 of 5

Thread: Results

  1. #1
    BOOSTED's Avatar
    Join Date
    Oct 2006
    Location
    ARUBA
    Posts
    359

    Results

    Well put the ski in the water check everything seems fine.

    Give it a shot boy hole shot is unbelievable only thing i noticed is that it pulls strong out of the hole than it drops a bit and than it goes hard again is this normall? Ski pulls fast on top really put a smile on my face . I outran a GPR 1300 with my girlfriend in the back

    Jerry ski seems a bit louder than normal (exhaust wise) and i'm getting water splashes on top of the motor. Checked every hose and all seems to be ok can it be the aluminum wire mesh and the exhaust letting go??

    And for speed when i went to get the GPS i left it at home But will test and bring it Sunday.

    Rpm's where like 7800-7900 my Damm mode button didn't want to change the display
    I'm still running the Stage II IC plastic pipes and BOV so i'm sure the BOV is leaking some boost, thats why i'm not going to pitch the prop just yet. Hopefully the guy over the shop around here will make me some nice alum pipes and i will put a greddy BOV on it.

    Jerry what do you think?

    http://smg.photobucket.com/albums/v5...t=Bryan029.flv





  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Take 1.5 mm pitch out of the trailing edge and that "flat spot" in the midrange acceleration will go away. You will also get a solid 8100 RPM's and will increase in top speed.

    Get some aluminum plumbing on that thing ASAP! The plastic is prone to boost leaks.

  3. #3
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    your only pulling that kind of RPM with these mods?

    SC III?
    42's Injectors?
    15/19r Skat prop?

  4. #4

    Join Date
    Jan 2006
    Location
    Puerto Rico
    Posts
    691
    Quote Originally Posted by meeper View Post
    your only pulling that kind of RPM with these mods?

    SC III?
    42's Injectors?
    15/19r Skat prop?
    Bro, his ski is running fine is the &#&* HEAT that is killing his moded RXP rpm's, today our local weather was @ 90 deg here in the caribbean

  5. #5
    BOOSTED's Avatar
    Join Date
    Oct 2006
    Location
    ARUBA
    Posts
    359
    Yup our heat & hot weather a night an day diff to the cold.

    Also i was checking the RPM on the anolog display cause my mode button didn't want to change modes.

    15/19 is also out of the box no pitching done just yet.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Franks 80+ mph videos and results from Saturday
    By Enufpwr in forum 4-Tec Performance
    Replies: 16
    Last Post: 09-11-2008, 01:54 PM
  2. What are your mod and results
    By Jrsrxp in forum 4-Tec Performance
    Replies: 33
    Last Post: 12-17-2007, 08:20 PM
  3. Today's test results 5/9/05
    By Jrsrxp in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-10-2005, 01:32 PM
  4. weekend results I'm happy
    By watermedic in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-09-2005, 06:01 PM
  5. My Mods and test results
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-05-2005, 07:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •