Results 1 to 5 of 5
  1. #1

    Polaris CDI wire placement. Please help

    I recently took apart my electric box to change out the trim motor/wires and am unsure where this orange wire plugs back into the bottom half of the box. Any ideas? It's a 1995 polaris sl 780. I'm pretty sure this wire has everything to do with the fact that the killswitch now doesn't work (motor will run with or without the lanyard plugged in). Thanks for the help. Click image for larger version. 

Name:	20140903_225500.jpg 
Views:	72 
Size:	139.9 KB 
ID:	340549


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    The ignition kill signal is a Black/Yellow wire. Make sure you have not accidentally connected a Black/Yellow wire to the Black terminal ground.

    The unconnected wire, is it actually Tan (Light Brown)?

  3. #3
    You're the best...I was sure hoping you'd be on here to answer my question. So I've labeled the black/yellow stripe wire which I did just hook back up (obviously to the wrong spot) Can you advise where both these wires should be plugged back into? I downloaded the service manual and just couldn't figure it out. Thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	revised ecu.jpg 
Views:	79 
Size:	146.0 KB 
ID:	340550  

  4. #4
    Figured it out. Thanks again.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by lockaby32 View Post
    Figured it out. Thanks again.
    For others who may read this later, the terminal board inside the electrical box is labeled for every wire color. There are only a couple of exceptions, but otherwise each wire color connects to the terminal as labeled.

    Black/Yellow wires connect to terminals marked BLK/Y, for example.
    Tan wire connects to TAN terminal.

    and so on

    The exceptions, which apply to specific model years and engine versions, are the Tan or Gray wires which may connect to a terminal labeled either TAN or GRY.

    On some red domestic carburetor engines the single wire from the CDI that is Red/Purple is converted to actually connect to the a Orange terminal on the board. This is documented as Service Bulletin PWC-00-05.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris virage 700 hesitation (please help)
    By sirdave4 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-13-2014, 07:13 PM
  2. 1999 Polaris Genesis fuel issue, Please help.
    By battline in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-23-2012, 08:07 PM
  3. 2001 Polaris Virage Starting Issues. Please Help
    By sofreshincali in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-23-2010, 12:42 AM
  4. wiring question please help
    By xprider02 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-29-2009, 08:30 PM
  5. Polaris Virage Display Flashes. Please Help!!!!
    By Lambrosfl in forum Polaris Open Discussion
    Replies: 2
    Last Post: 10-19-2006, 08:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •