Results 1 to 5 of 5
  1. #1
    O'side GTX's Avatar
    Join Date
    Aug 2014
    Location
    Oceanside, California
    Posts
    16

    Fuel pump power supply

    Fuel pump wiring diagram anyone?
    i just replaced my fuel pump, and installed a Walbro. But I have not been able to figure out why I'm not getting my fuel pump to run. It wasn't working before, I've checked all fuses and reboot eyed the ECM but there seems to be no power to the pump. What do I do next?


  2. #2
    O'side GTX's Avatar
    Join Date
    Aug 2014
    Location
    Oceanside, California
    Posts
    16
    Btw it is 2005 Sea Doo GTX limited.

  3. #3
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    do you have power?
    the ecu sends a ground to start the pump

  4. #4
    O'side GTX's Avatar
    Join Date
    Aug 2014
    Location
    Oceanside, California
    Posts
    16
    Not sure how to check. But I hooked pump to 12 volt source and got pump to run. How do I check the ecu power? Could it be my regulator.

  5. #5
    O'side GTX's Avatar
    Join Date
    Aug 2014
    Location
    Oceanside, California
    Posts
    16
    Chris,
    Thanks! You were absolutely correct! The problem is at the connector to the ECU for the ground. Suggestions on fixing the connection?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pump stopped pumping a good supply of fuel, the pulse line is not pulsing?
    By thetolleyman in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-25-2014, 06:14 AM
  2. 03 GTX Power to Fuel pump issue
    By jamalama in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-22-2014, 08:08 PM
  3. Fuel pump won't turn on unless "power up" wire is grounded.
    By BailYes in forum Yamaha ECU Support
    Replies: 7
    Last Post: 08-23-2012, 12:09 AM
  4. Please help, no power to fuel pump 2005 12f
    By keanu in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 12-15-2010, 11:41 PM
  5. STX 15F No power to the Fuel Pump
    By stxnewbi in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 09-26-2010, 08:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •