Results 1 to 6 of 6
  1. #1

    Join Date
    Aug 2013
    Location
    norway,me
    Posts
    88

    impeller came off.

    I have a 2002 virage txi that spun the impeller off and locked the motor up.got it apart and the motor is fine.y would it do that?


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Check you jet pump bearings. If the stub shaft suddenly seizes, the threads could strip and free the impeller. The jet pump, which bolts to the hull, transfers the thrust forward to propel the craft. Since the impeller technically pulls on the stator, if the threads strip, it will continue to spin forward and pull itself off the stub shaft...

  3. #3

    Join Date
    Aug 2013
    Location
    norway,me
    Posts
    88
    the threads do look funny like thet may have pulled off.but the bearings seem fine.the short spacer has a deep gouge in the seal area and the pump extension is ground out rearward of the usual area of running.where the impellar normally runs is fine.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    The stub shaft needs to be 100% straight and undamaged. Do not reuse the old stub shaft if the threads are damaged or the impeller wobbles when installed.

    Since you have it apart it makes sense to replace the bearings and seals in the jet pump status hub.

    Replace the spacer behind the impeller if it is damaged.

  5. #5
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by xltier View Post
    the threads do look funny like thet may have pulled off.but the bearings seem fine.the short spacer has a deep gouge in the seal area and the pump extension is ground out rearward of the usual area of running.where the impellar normally runs is fine.
    I have a good used stub shaft if you need a replacement. PM me if interested......

  6. #6

    Join Date
    Aug 2013
    Location
    norway,me
    Posts
    88
    I need a stub shaft-spacer-impeller and extension housing.i now see there should of been bumpers on each end of shaft.they were not there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Impeller nose cone came off....
    By Water Pig in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-22-2009, 08:15 PM
  2. Replies: 2
    Last Post: 05-04-2008, 09:27 PM
  3. Just came off lake. cant believe speed!
    By piper250 in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-07-2007, 03:25 PM
  4. Mirrors came off
    By RapidFire Inc. in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-23-2007, 12:07 AM
  5. Set Button came off and loosing take off speed!
    By Compwhiz82 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-11-2005, 02:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •