Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Question about winterizing when pumping RV antifreeze.

    As bad as I hate to say it, its starting to get close to that time for us to start to put the toys away for the winter...still keeping our fingers crossed for a few more good riding days..but during that time I am trying to get all my stuff together to winterize all 3 ski's. I have winterized my 2 stroke ski's without any problems..but now I have 3 4techs and want to make sure I get this right. I bought a small submersible pump to put in a 5 gal bucket of RV antifreeze that will pump it thru the flushout adaptor. After I run the antifreeze thru is there anything else I need to do to make sure all the water is out? I understand I need to fog, oil change etc..etc...but I just want to make sure I get all the water out..as always thanks for your help!


  2. #2
    R-Doo's Avatar
    Join Date
    Sep 2006
    Location
    Minnesota
    Posts
    833
    +1
    77
    I usally hit the flushout port with the air gun first, then pump AF till it comes out pink. That should dilute the water in the waterbox enough.
    Along with the oil, filter, Stabil. fog.
    Fresh plugs go in after first start in Spring.
    So far this has worked for me since 2006.

  3. #3
    Is the normal pink antifreeze good enough..I see where some of the guys use -100F antifreeze at like $12 a gallon..We live in Southern Ohio where we might see -5 once maybe twice all winter.

  4. #4
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92
    Quote Originally Posted by ashnic View Post
    Is the normal pink antifreeze good enough..I see where some of the guys use -100F antifreeze at like $12 a gallon..We live in Southern Ohio where we might see -5 once maybe twice all winter.
    Standard pink RV antifreeze should be fine, especially if you blow out the line first as mentioned above.

  5. #5
    Captain Spalding's Avatar
    Join Date
    Jun 2013
    Location
    Olathe,Kansas
    Posts
    241
    +1
    23
    Quote Originally Posted by R-Doo View Post
    I usally hit the flushout port with the air gun first, then pump AF till it comes out pink. That should dilute the water in the waterbox enough.
    Along with the oil, filter, Stabil. fog.
    Fresh plugs go in after first start in Spring.
    So far this has worked for me since 2006.
    Exactly how I do mine.

  6. #6
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    I have attached a bilge pump to the bottom of a bucket. I fill the bucket with water, run the machine, turn the pump on. when it gets to the bottom, pour a gallon or 2 of antifreeze in there. rev the engine to clear the water from the water box. run the bucket out of antifreeze, and rev it some more then your done

  7. #7
    There is nothing to drain or open at that? Just wanting to make sure..

  8. #8
    Quote Originally Posted by R-Doo View Post
    I usally hit the flushout port with the air gun first, then pump AF till it comes out pink. That should dilute the water in the waterbox enough.
    Along with the oil, filter, Stabil. fog.
    Fresh plugs go in after first start in Spring.
    So far this has worked for me since 2006.
    Hate to ask a stupid question but where is the flush hose connection on a GTI SE?
    Waiting to winterize as I want at least one ride before its time to shovel snow!!

  9. #9
    xxx2's Avatar
    Join Date
    Oct 2006
    Location
    panama city bch, Fl
    Posts
    421
    +1
    35
    At the Back right beside the pump jet it's a garden hose connection

  10. #10
    Is there any difference or anything different need done when pumping antifreeze thru a SC Jetski and a non SC jetski? I ask because of the intercooler?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. question about winterizing 95 sl650
    By parrothead306 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 11-15-2009, 11:08 AM
  2. Questions About An Extended Pump on a 95 SLT750
    By way2much2do in forum Polaris Open Discussion
    Replies: 33
    Last Post: 07-01-2009, 03:28 PM
  3. Question about winterize
    By mixx911 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 10-14-2008, 12:43 PM
  4. Question about winterizing an SLH
    By diesel359 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 11-10-2007, 03:45 PM
  5. Question about winterizing without the carbs on GP1200R
    By rehr0001 in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 10-05-2007, 11:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •