Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Houston, TX
    Posts
    570
    +1
    51

    2007 Ultra 250X Low Compression

    Just bought a 2007 Ultra 250X for a parts ski (cheap) price. 57 hours. Ski is clean, so I'd like to fix it. Mods are a Riva exhaust kit and Riva ride plate. Previous owner rebuilt the supercharger, new intercooler, fuel pump, hoses, but could not diagnose the problem correctly. Starts/runs, but he said would not get over 30mph.

    I brought the ski home, checked compression and am seeing 85psi across all four holes. Two different gauges, one is a Snap-On. Any other ideas before I pull the head and have it rebuilt?

    Smokeysevin has already ordered pump bearings and will handle that for me.

    Thanks,
    -Greg


  2. #2
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Houston, TX
    Posts
    570
    +1
    51
    Odd that it's even compression... After talking with WFO, I'm going to check timing to make sure a cam didn't slip a tooth...

  3. #3
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511
    Check air intake horn and the super charger. The veins have a coating that maintains the tolerance. Once thats cooked it is no good. I/C and belt tension.
    There's folks that know more than myself here so....

  4. #4
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Houston, TX
    Posts
    570
    +1
    51
    After pulling the valve cover, and moving the motor to TDC, it was clear that the exhaust cam was off a tooth.

    Unfortunately while removing the cam cover a couple of times, the small dowel pin dropped into #1 cylinder. Working on fishing that out, then I'll reassemble and do another compression test.

    I've never realigned the cams while the motor is in the ski, always on the bench. Trickier for sure.

  5. +1 by:


  6. #5
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Houston, TX
    Posts
    570
    +1
    51
    Was able to fish the dowel pin out of #1 with a pin magnet (thanks macGruber!), aligned cams and buttoned everything back up. Now I'm seeing 110 PSI even across all cylinders on a cold motor.

    What is the normal cold compression on a 250X? Shop manual says 173-261, which I know is wrong for a boosted motor.
    Last edited by boudin; 09-12-2014 at 09:22 PM.

  7. #6
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Houston, TX
    Posts
    570
    +1
    51
    Quote Originally Posted by rlovebk View Post
    Check air intake horn and the super charger. The veins have a coating that maintains the tolerance. Once thats cooked it is no good. I/C and belt tension.
    There's folks that know more than myself here so....
    Thanks. Checked the intake horn, and the previous owner had replaced the supercharger and intercooler when throwing parts at it to fix.

  8. #7
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Houston, TX
    Posts
    570
    +1
    51
    Finally was able to take her out today. 56 MPH (GPS), 6950 max RPM and about 9 psi of boost. Compression is still even at 110. I also did a run with the seat off, and no change.

    I'm still curious as to why the exhaust cam was off a tooth. What is good compression for this ski?

  9. #8
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,008
    +1
    283
    It would seem reasonable to me that, considering the mods that the previous owner did, perhaps he pulled the head.

  10. #9
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Houston, TX
    Posts
    570
    +1
    51
    Quote Originally Posted by steve45 View Post
    It would seem reasonable to me that, considering the mods that the previous owner did, perhaps he pulled the head.
    Thanks. I've done some searches on GH and will pull the intercooler to make sure it's clean. But I can't seem to find acceptable compression numbers for the '07 250X. Does anybody know if 110 is normal?

  11. #10
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    I wouldnt be to stressed as there can be big variances between testers. If there all equal I would leave it be.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ultra 250x low compression?
    By marvin willis in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 05-05-2014, 05:50 PM
  2. 2007 kawi ultra 250x low hours parting it out!
    By Kawi260_crusier in forum Kawasaki Classifieds
    Replies: 16
    Last Post: 05-11-2013, 02:09 PM
  3. 2007 Kawasaki Ultra 250X low rpm
    By saynotospam in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-10-2011, 09:57 PM
  4. FS 2007 Ultra 250X - LOW hours- very unique
    By Huter Boi in forum Kawasaki Skis
    Replies: 3
    Last Post: 12-03-2009, 01:26 PM
  5. new kawasaki 2007 ultra 250x RED OR BLUE OTD 11,300
    By XRIDER in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 04-12-2007, 10:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •