Results 1 to 4 of 4
  1. #1

    Bad jet pump/impeller bearings?

    Click image for larger version. 

Name:	photo 1.JPG 
Views:	67 
Size:	107.7 KB 
ID:	341782Click image for larger version. 

Name:	photo 2.JPG 
Views:	70 
Size:	99.6 KB 
ID:	341783Click image for larger version. 

Name:	photo 3.JPG 
Views:	58 
Size:	77.7 KB 
ID:	3417841999 GTX Seadoo

    After getting a quote from a local mechanic, I was not willing to pay $1200 for a jet pump replacement.

    Basically the compartment filled halfway with water one day on the lake. After I drained it I tried starting it again and heard a LOUD screech from the back...I mean ear piercing loud. After I took it out I noticed the cone to my impeller was missing. Obviously the impeller was not getting any oil through it. Would that cause the loud screech? The area where the cone covers has some rust and the impeller will not turn at all by hand. I realize I may have a couple things to replace now. Anyone have tips on how I should go about this? I am pretty handy so I'd rather not take it into the shop.

    Also wanted to add...the seadoo would crank for about 2-3 seconds while pushing the throttle. Then the loud screech would come and the ski dies.

    Thanks!
    Last edited by RyMusic; 09-14-2014 at 05:09 PM.


  2. #2
    davenoscott's Avatar
    Join Date
    Jun 2014
    Location
    Asheville, NC
    Posts
    69
    +1
    1
    I just recently rebuilt the jet pump on my friends 00 GTX. It's a very simple process. Order a rebuild kit and get to work. Just need to press in the bearings and it sounds like you need a new cone.

  3. #3
    davenoscott's Avatar
    Join Date
    Jun 2014
    Location
    Asheville, NC
    Posts
    69
    +1
    1
    I was thinking about it and you may need a new impeller shaft.

  4. #4
    Quote Originally Posted by davenoscott View Post
    I was thinking about it and you may need a new impeller shaft.

    Yep! Got the impeller and drive shaft out. She runs great. At least I know it's only the impeller now.

    Ordering the replacement parts today or tomorrow. I estimate around $180.00 needed if my impeller shaft is out too. I'm going to order the tool first to make sure the shaft is bad. Think I can use the same impeller blade? It's not THAT dinged up. Just a little in one spot. Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Jet pump impeller stuck, bearing removal
    By Porkchop_ina_Can in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-08-2013, 08:22 PM
  2. Replies: 3
    Last Post: 09-14-2012, 05:08 AM
  3. STX15 Jet pump impeller stuck on driveshaft
    By squared in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 09-18-2011, 09:45 PM
  4. jet pump impeller Question pic included
    By rdizz81 in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-22-2010, 03:27 PM
  5. friend sucked up rocks on my 06-1300r, impeller bad, jet pump doesnt look good
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 23
    Last Post: 08-03-2007, 07:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •