Results 1 to 5 of 5

Thread: Rxp cavitates

  1. #1

    Join Date
    Nov 2008
    Location
    greece,Europe
    Posts
    94
    +1
    8

    Rxp cavitates

    Hello guys I run an rxp 155 ss wear ring j pipe solas sr cd 11/19 air intake pump wedge intake grate and when I hit the throtle it cavitates(spins like a car with damage clutch)till 7350 and then it gets in plane.if I pull the trigger more gently it's ok with a top speed 63 mph gps checked.what seems to be the problem.no cavitation at all except before gets in plane


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Check the condition of the prop blades and that there is no damage to them,Check your carbon seal/accordian boot assembly as it may be worn and in need of replacement...And check your pump shoe for damage or cracks...

  3. #3

    Join Date
    Nov 2008
    Location
    greece,Europe
    Posts
    94
    +1
    8
    Impeller is brand new and it's pitch blocked from jerry.pumps shoe is in good condition.if was the carbon ring doesn't have to fill the hull with water?

  4. #4
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,996
    +1
    1,477
    Sit on your knees on the rear of the ski, reach down and try to pull the rubber boot toward the rear. If it moves easily, replace it. Might want to use the SBT tool to line up the engine/drive shaft/ pump. Good luck!

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Nope on the carbon seal...it can be worn/weak and not have to leak water...All it takes is a little bit of weakness to seperate enough to allow it to cavatate....also check your motor mounts to see if they are not broke...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help me with RXP Cavitation problem!!!
    By Five 0 in forum 4-Tec Performance
    Replies: 31
    Last Post: 08-21-2012, 08:23 AM
  2. after solas install 2004 rxp cavitates
    By Robert Ruda in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-24-2011, 02:32 PM
  3. 2004 rxp cavitation
    By martin_7238 in forum 4-Tec Performance
    Replies: 13
    Last Post: 12-17-2010, 05:15 PM
  4. RXP Cavitation
    By RXPSC215 in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-07-2008, 01:49 PM
  5. Rxp cavitating badly, water in hull
    By kenshin89 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-21-2006, 12:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •