Results 1 to 7 of 7
  1. #1

    Join Date
    Aug 2014
    Location
    Jackson, Tn
    Posts
    35

    97 sltx 1050 rebuilt engine

    I need a rebuilt engine or get mine reworked. I got 2 fried pistons! Need best way to go.


  2. #2
    RLACEMAN's Avatar
    Join Date
    Aug 2011
    Location
    Random Lake WI
    Posts
    884
    +1
    54
    A rebuilt engine is the best way to go, but you need to find out what caused the 2 fried pistons in the first place, carburetors are usually the problem they should be rebuilt, new fuel lines from inside the tank to the carbs, fresh fuel pump, make sure there is no problem with the oil injection, or did the motor overheat, crankshaft bearings or seals going bad, using 87 octane fuel with ethanol can also cause this.

  3. #3

    Join Date
    Aug 2014
    Location
    Jackson, Tn
    Posts
    35
    Quote Originally Posted by RLACEMAN View Post
    A rebuilt engine is the best way to go, but you need to find out what caused the 2 fried pistons in the first place, carburetors are usually the problem they should be rebuilt, new fuel lines from inside the tank to the carbs, fresh fuel pump, make sure there is no problem with the oil injection, or did the motor overheat, crankshaft bearings or seals going bad, using 87 octane fuel with ethanol can also cause this.
    Where or who is the best place to get rebuild. I Just rebuilt the carbs, new fuel lines, new stator. It was sluggish before all the reworking. I thought the stator was the problem, high ohm readings. After all this I did comp. ck. and 1 was 0, 1 40, 1 60.

  4. #4

    Join Date
    Jun 2008
    Location
    windsor ont
    Posts
    640
    +1
    8
    if the cylinders are no good i have 3 perfect ones

  5. #5
    RLACEMAN's Avatar
    Join Date
    Aug 2011
    Location
    Random Lake WI
    Posts
    884
    +1
    54
    If all 3 cylinders are bad I would suspect an oil injection failure or it was overheated. The only place that I know of for rebuilt motors is SBT, some here on this site don't care for them, but I know of 2 people who used them, both ran fine, the one is now on it 9th year of use with no problems, the other was sold after a couple years of use, so we don't know how that one held up. I bought a set of rebuilt cylinders from them several years ago & still running fine.

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Any pics of the failure?

  7. #7

    Join Date
    Aug 2014
    Location
    Jackson, Tn
    Posts
    35
    Quote Originally Posted by BryanP View Post
    Any pics of the failure?
    I took pictures, but I'm a computer dummy. The mag and PTO look like burned charcoal, the center looks o.k. I did a carb rebuild, with new fuel lines, it ran o.k. on my pond for abouit 30 min. It still only would run at about 1/2 RPMs. I checked stator and found a high ohm reading so I changed it out. Then it wouldn'd start. checked Comp, Mag-30, center-60, PTO-0. Took heads off and found 2 pieces of burned charcoal. I would post picts but I don't know how!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 SLTX 1050 In Upstate NY New York
    By mccann316 in forum Polaris Classifieds
    Replies: 5
    Last Post: 05-02-2008, 09:41 AM
  2. '97 SLTX 1050 firing problem
    By chrismc in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-17-2007, 08:56 PM
  3. Putting new rings on a 97 sltx 1050
    By grifter in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-23-2007, 07:54 AM
  4. weak power on 97 sltx 1050
    By grifter in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-13-2007, 05:02 PM
  5. 97 SLTX 1050 Ignition Upgrade???
    By mccann316 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 03-08-2007, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •