Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    oz_speed's Avatar
    Join Date
    Feb 2011
    Location
    United Kingdom
    Posts
    371
    +1
    1

    Using Oil advice needed

    Help and advise needed

    i have a 2007 RXP, open loop cooling. I am loosening a lot of oil and think it must be passing in the oil cooler or head gasket gone letting the oil in to the cooling system then out. Lots of oil around ski when sat in water.

    As as anybody seen this before and if so what do you think it could be.


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Could be the water pump shaft seal too...

  3. #3
    oz_speed's Avatar
    Join Date
    Feb 2011
    Location
    United Kingdom
    Posts
    371
    +1
    1
    Anybody take a best guess were to start or most common fault?

  4. #4
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    I would check the driveshaft seal/boot. Put your hand down in front of the driveshaft, and check the bottom of the black rubber boot. If that seal is leaking, it will drip oil into the bottom, and the siphon bilge will pull that oily water out the back, leaving an oil slick near the ski like you describe.

    Best thing is to clean/dry the engine well, then check closely for leaks after running it. They don't usually leak when not running. First thing I would check is the driveshaft seal, they do leak sometimes, especially after pulling the driveshaft and putting it back in.

  5. #5
    oz_speed's Avatar
    Join Date
    Feb 2011
    Location
    United Kingdom
    Posts
    371
    +1
    1
    I have pulled the Scer hose and found some oil in there. There was also a very small amount in intercooler.
    I have attached a few photos.
    Do you think it could be the seal in the Scer. I am running a mini rude with about 20 hours on it. I think it has the oem seal fitted in there.

    I topped the oil up last time I was out on ski and had to put around 2l oil in yesterday again. Did about 60-90mins on ski and oil light came on. Oil was at bottom of the stick again.

    Took the spark plugs out and they look ok, so I am not thinking it is passing up the bores. No oil in catch can just a small amount of water.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	42 
Size:	78.3 KB 
ID:	342284   Click image for larger version. 

Name:	image.jpg 
Views:	40 
Size:	129.8 KB 
ID:	342285   Click image for larger version. 

Name:	image.jpg 
Views:	38 
Size:	96.1 KB 
ID:	342286   Click image for larger version. 

Name:	image.jpg 
Views:	40 
Size:	99.5 KB 
ID:	342287   Click image for larger version. 

Name:	image.jpg 
Views:	42 
Size:	105.8 KB 
ID:	342288  
    Last edited by oz_speed; 09-22-2014 at 06:57 AM.

  6. #6
    oz_speed's Avatar
    Join Date
    Feb 2011
    Location
    United Kingdom
    Posts
    371
    +1
    1
    Quote Originally Posted by Vern View Post
    I would check the driveshaft seal/boot. Put your hand down in front of the driveshaft, and check the bottom of the black rubber boot. If that seal is leaking, it will drip oil into the bottom, and the siphon bilge will pull that oily water out the back, leaving an oil slick near the ski like you describe.

    Best thing is to clean/dry the engine well, then check closely for leaks after running it. They don't usually leak when not running. First thing I would check is the driveshaft seal, they do leak sometimes, especially after pulling the driveshaft and putting it back in.

    No pil in hull of ski or around driveshaft.

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Richard,
    I would say your front oil seal in the Scer is bad...Time to replace it with a Viton...

  8. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Sounds like snoman is right on the SC seal, But if you are also seeing an oil sheen after sitting in the water, your Oil cooler is leaking as well. My RXP is open loop, and noticed the same thing when sitting after shutdown, and at idle while doing sharp turnsi Could see drops of oil coming from rear water dump, then sheen on the water. Changed it out, and no more leaks.

  9. #9
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,248
    +1
    544
    is there oil in your cooling system? I find it hard to believe the supercharger seal would cause that much oil to be lost in such a short time, anything is possible though.

    If your oil is infact making its way into the cooling system, its very possible the PTO cover gasket is bad. I had this happen to me one time.

  10. #10
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    If your open loop your waterpump shaft is rusted and the seals are shot.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Buying used Yamaha FX HO - Advice needed
    By Rapson in forum Yamaha Open Discussion
    Replies: 7
    Last Post: 10-18-2013, 07:34 PM
  2. I need someone oil advice and instructions please>>>>>
    By noshowallgo in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-04-2010, 09:51 PM
  3. Oil turmoil..... need advice
    By fireball451 in forum 2-Stroke Performance
    Replies: 10
    Last Post: 05-10-2010, 09:29 PM
  4. Advice needed on what to use on Ultra Black Parts
    By tomgtv in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 07-22-2007, 12:59 PM
  5. STX 15 f oil light advice needed
    By Aquaholic in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-13-2007, 02:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •