Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 46

Thread: 2014 RXPX Issue

  1. #1
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92

    2014 RXPX Issue

    I bought the ski a couple weeks ago with 4 hours on it. I put 2 hours on it last week without any issues. I took the ski out today for a long ride and immediately noticed a weird sound like engine was struggling or grinding or something. I wasn't sure if there was actually an issue or if I was just not familiar with the ski yet and worrying about nothing. I checked the grate and impeller, they look clear. About 2 hours into the ride, I went through a fairly long no wake zone. When exiting, I hit the gas and the ski went no where. I believe the RPMs were up to about 6,000. That happened a couple times and then I hit the throttle again and the ski drove as it did before.

    I did notice that when I bought the ski at 4 hours, the engine oil looked brand new (as it should). Now at 8 hours, the oil is considerably darker. Could that be an indicator of an issue or is that just because of the fact it is break in oil?

    I'm pretty lost on this one. Any help is appreciated.


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    classic symptoms of a SC failure
    probably only the clutch
    but it could be more

  3. #3
    ProZadoX's Avatar
    Join Date
    Jan 2008
    Location
    Ottawa, Canada
    Posts
    351
    +1
    55
    If it's a SC failure, STOP using it and to the dealer, pronto. This ski got ridden pretty hard for a failure at just 6 hours, no?

  4. #4
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92
    Quote Originally Posted by skidoochris View Post
    classic symptoms of a SC failure
    probably only the clutch
    but it could be more
    Great. It wouldn't throw a code for that? How would I check? I'd like to confirm before I take it to the dealer.

    Quote Originally Posted by ProZadoX View Post
    If it's a SC failure, STOP using it and to the dealer, pronto. This ski got ridden pretty hard for a failure at just 6 hours, no?
    I didn't own it for the first 4 but I doubt it. He had it on a very small local lake. The two hours that I put on it were not rough at all. I was on a 5 mile lake without any other boat traffic, it was really calm.

  5. #5

    Join Date
    Mar 2013
    Location
    Appleton, WI
    Posts
    588
    +1
    93
    Its covered under warranty so take in. Best guess would be a clutch issue.

    If its anything to do with the supercharger the last thing you want is a total melt down. Always better error on the side of caution.

  6. #6
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    I dont think it is a clutch issue...Especially if it rode like it did before the no wake zone, and only having 6 hours on it....

    Without seeing it or riding it, I cant offer anything but will be interested to see what it turns out to be....

  7. #7
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92
    Quote Originally Posted by skylolow View Post
    Its covered under warranty so take in. Best guess would be a clutch issue.

    If its anything to do with the supercharger the last thing you want is a total melt down. Always better error on the side of caution.
    I don't have the greatest confidence in the local dealership, I'd like to at least diagnose the problem if I can.

    Quote Originally Posted by Tiny View Post
    I dont think it is a clutch issue...Especially if it rode like it did before the no wake zone, and only having 6 hours on it....

    Without seeing it or riding it, I cant offer anything but will be interested to see what it turns out to be....
    I thought it was making an abnormal buzzing type of noise from the moment I put it in the water but was not sure if it was all in my head. After the no wake zone, I began to worry because I actually experienced a tangible issue. It was like the ski was revving but not picking up speed. After it happened, I rode all the way (about 20 miles) back to the launch at 35 - 40 MPH.

    Could the oil be an indicator or does the break in oil tend to change color from 4 to 8 hours?

  8. #8
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    did the oil get milky or dark?
    brake in oil is just standard oil, non synthetic

  9. #9

    Join Date
    Aug 2013
    Location
    Connecticut
    Posts
    99
    +1
    19
    It could have a leaking intercooler already, i know its a long shot but sounds like the symptoms of slight water ingestion, and congrats on buying the ski, i actually was looking at it on craigslist but it seemed weird that the guy was selling it with only 4 hours, hopefully nothing is really wrong with it

  10. #10
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    It almost sounds prop related, cracked hub splines ? Did the ski vibrate when driving back?

  11. +1 by:


Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Top Speed on New 2014 RXPX & RXTX
    By joe w in forum 4-Tec Performance
    Replies: 31
    Last Post: 10-17-2014, 08:26 PM
  2. FS - Parts 2012-2014 rxpx or tx athena ecu with extras
    By IM2FAST4U in forum Sea Doo Classifieds
    Replies: 11
    Last Post: 10-05-2014, 01:30 AM
  3. New 2014 RXPX
    By ryandi2 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-07-2014, 08:27 PM
  4. 2014 RXPX breaking in RPM??
    By DUCKY UK in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-30-2014, 08:19 PM
  5. 2014 FZR vs 2014 RXPX
    By abmobil in forum Yamaha PWC Performance (4-stroke)
    Replies: 30
    Last Post: 03-18-2014, 01:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •