Results 1 to 6 of 6
  1. #1
    indosurf's Avatar
    Join Date
    Oct 2011
    Location
    Caribbean
    Posts
    65
    +1
    1

    Low on power/mph

    Hey all,

    I have a 2007 gets with 50 hrs on it.
    take it out once every couple months in the ocean.
    last time out it was very low on power. Top speed was only about 40 mph.
    In lower rpms engine seemed fine but an attempt at wide open would cause hesitation and sputtering.
    rode ski for about an hour, took a break and had a very hard time restarting it, took about 12 tries luckily it has a brand new battery. Back home on the trailer the throttle seemed fine, snappy and responsive thru out the rpm range.

    any thoughts?

    thanks


  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,179
    +1
    97
    Any fault codes?
    If your supercharged (GTX Limited) then start wit the super charger. Bearing failure? Clutch failed.
    If it failed and you rode it that much, you may have trashed the bearings.
    Check all hoses, could be just a boost leak
    How does the oil look, any milkyness?
    Coolant level good and look in the bottle?
    Pump clear? no garbage in it?

  3. #3
    Mine did similar was a fouled plug.

  4. #4
    indosurf's Avatar
    Join Date
    Oct 2011
    Location
    Caribbean
    Posts
    65
    +1
    1
    yes, supercharged
    replaced the ceramic washers 25 hrs ago
    oil and coolant are fine. All hoses are tight,
    going to replace plugs (fingers crossed)
    how do I check if pump is clogged?
    fuel pump or jet pump??

  5. #5
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,179
    +1
    97
    Jetpump, but yes, change the spark plugs!

  6. #6
    indosurf's Avatar
    Join Date
    Oct 2011
    Location
    Caribbean
    Posts
    65
    +1
    1
    How do I check if jet pump is clogged?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 15f low on power after pump swap
    By angiebillw in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 06-21-2014, 10:03 PM
  2. 2004 XLT 1200 low on power
    By ramster in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-31-2012, 09:10 PM
  3. STX-R - low on power
    By toomanytoys in forum Kawasaki PWC Performance (2-stroke)
    Replies: 26
    Last Post: 08-01-2009, 05:51 PM
  4. a little low on the MPH with mods
    By Chris0060 in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-18-2009, 07:57 PM
  5. Low on power
    By fullshift in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-21-2008, 11:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •