Results 1 to 3 of 3
  1. #1

    06 sea doo rxp 4 tec electrical problem

    2006 215 HORSE Supercharged. Initial problem: Battery died, I replaced rectifier, battery died again but not sure the rectifier is the problem. OTHER ELECTRICAL ISSUES: 1. Red warning light always on. 2. Low fuel was on, now NO fuel on display even when full of gas. 3. PREVIOUSLY the machine acted as though it needed to be warmed up. Would but would not accelerate for approx. 5 minutes then ran fine. NOW, same problem but regardless of how warm it is, hit the throttle and it just bogs down with little acceleration. You can slowly accelerate to 40 mph, after 40 it bogs down regardless of how much throttle used. to get to 40 you cannot use full throttle, maybe half. CLOSING: The engine is in good shape, full of oil etc. I have checked all cable connections, New battery, New rectifier. Essentially the machine is useless. My question is, is this a simple replace (xyz) part or is part of a more complex issue, replace the entire electrical system ? Or is it an electrical problem ?


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,280
    you need an experienced tech to unravel what's going on

    to get help here, focus in on ONE issue and then work your way thru.

    so...

    let's start on the charging system

    get a _good_ voltmeter...

    read battery volts at standing..then start engine, read battery volts at idle then at 5k rpm

    report back with the numbers and we can go from there.

    nothing else is important a the moment, having the battery charge while the engine is running is step one....

  3. +1 by:


  4. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by KEN TODD View Post
    2006 215 HORSE Supercharged. Initial problem: Battery died, I replaced rectifier, battery died again but not sure the rectifier is the problem. OTHER ELECTRICAL ISSUES: 1. Red warning light always on. 2. Low fuel was on, now NO fuel on display even when full of gas. 3. PREVIOUSLY the machine acted as though it needed to be warmed up. Would but would not accelerate for approx. 5 minutes then ran fine. NOW, same problem but regardless of how warm it is, hit the throttle and it just bogs down with little acceleration. You can slowly accelerate to 40 mph, after 40 it bogs down regardless of how much throttle used. to get to 40 you cannot use full throttle, maybe half. CLOSING: The engine is in good shape, full of oil etc. I have checked all cable connections, New battery, New rectifier. Essentially the machine is useless. My question is, is this a simple replace (xyz) part or is part of a more complex issue, replace the entire electrical system ? Or is it an electrical problem ?
    ECU, & coil packs are going bad.
    Change the coils first with known good ones, and see if it helps. The fuel display problem is your ECU. I just had the same thing happen to my 07 RXT. I was getting all kinds of beeps, and codes, Also thinking the battery was dying, and not charging, but it was . I thought the fuel pump was dying, due to power loss, and throwing low volts codes. It did finally die on the way back to the ramp, and would not restart. Would spin over fast, and had weak spark, but would not run.
    Once I changed the ECU, the fuel display came back, but would only sputter once in a few trys. I changed the spark plugs, and topped off the battery, and would still not run, until we changed all 3 coil packs, then Bam, Runs great again. hope this helps.

    http://www.greenhulk.net/forums/showthread.php?t=218691

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sea Doo RXP 2005 Starting Problems
    By rolo2230 in forum Sea Doo Open Discussion
    Replies: 21
    Last Post: 05-17-2010, 10:30 AM
  2. SOLD FS: Used OEM Sea Doo RXP Cover for 04-06 RXP
    By JAG in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 01-05-2009, 08:41 PM
  3. 05 Sea-Doo RXP Problem!
    By eimutisj in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-03-2007, 06:24 PM
  4. '06 Sea Doo GTX 4 Tec Battery problems!
    By ohanaporvida in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-01-2007, 06:31 AM
  5. stock 06 sea doo rxp RPM gauge shows 8360
    By XRIDER in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-27-2007, 05:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •