Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Sep 2014
    Location
    Gold Coast
    Posts
    91
    +1
    25

    This doesn't look right....Engine compartment

    Me again!

    So I was just having a little nosey through the engine compartment with my torch and I thought I saw moisture at the bottom of the hull. So I stuck my hand in and felt a pretty large pool of water right underneath the engine. Anyway, after soaking it up with a chamois, I noticed the clear tube just flopping around.

    Now, I'm by no means mechanically minded but shouldn't this tube be attached to something? Is it the coolant tube from the reservoir?

    Click image for larger version. 

Name:	photo (8).jpg 
Views:	140 
Size:	60.5 KB 
ID:	342470


  2. #2
    JohnSWE's Avatar
    Join Date
    Oct 2013
    Location
    Stockholm, Sweden
    Posts
    158
    +1
    25
    I think it should be connected to the coolant reservoir that you see in the photo.

  3. +1 by:


  4. #3
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    thats coolant overflow.

    Leave it

  5. #4
    JohnSWE's Avatar
    Join Date
    Oct 2013
    Location
    Stockholm, Sweden
    Posts
    158
    +1
    25
    Quote Originally Posted by GasResearch-VT.SE View Post
    thats coolant overflow.

    Leave it
    Ohh ok! Thought it was fully closed.

  6. #5
    Q in Arizona's Avatar
    Join Date
    May 2013
    Location
    Phoenix, Az
    Posts
    30,396
    +1
    7,288
    So where is the water in the hull coming from?

  7. #6

    Join Date
    Sep 2014
    Location
    Gold Coast
    Posts
    91
    +1
    25
    Quote Originally Posted by GasResearch-VT.SE View Post
    thats coolant overflow.

    Leave it
    So just direct it to the bottom of the hull?

  8. #7

    Join Date
    Sep 2014
    Location
    Gold Coast
    Posts
    91
    +1
    25
    Quote Originally Posted by Q in Arizona View Post
    So where is the water in the hull coming from?

    I washed down the engine compartment on Sunday after my run as I noticed some spots of salt around the area. I watched the Sea doo video and they recommend to lightly wash down the engine compartment.

    I think there's a bit of a flat spot in the bottom of the hull underneath the engine and I can't tilt it high enough due to the trailer rollers stopping it going too far.

  9. #8
    Q in Arizona's Avatar
    Join Date
    May 2013
    Location
    Phoenix, Az
    Posts
    30,396
    +1
    7,288
    Quote Originally Posted by Flipfloptrader View Post
    Quote Originally Posted by Q in Arizona View Post
    So where is the water in the hull coming from?

    I washed down the engine compartment on Sunday after my run as I noticed some spots of salt around the area. I watched the Sea doo video and they recommend to lightly wash down the engine compartment.

    I think there's a bit of a flat spot in the bottom of the hull underneath the engine and I can't tilt it high enough due to the trailer rollers stopping it going too far.
    Ahhh...that makes sense.

  10. #9
    dolson's Avatar
    Join Date
    Apr 2010
    Location
    Massachusetts
    Posts
    635
    +1
    86
    I have the same problem with getting the water out of the foot wells. Trailer just doesn't tilt far enough

  11. +1 by:


  12. #10
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Take it for a spin around the block and park it up

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. this doesnt look right to me
    By rxpxsam in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 09-09-2008, 09:43 AM
  2. crankshaft seals - does this look right?
    By sea~smith in forum Polaris Open Discussion
    Replies: 3
    Last Post: 12-30-2007, 05:02 AM
  3. does this look right?
    By rxpblast in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 10-21-2007, 08:24 AM
  4. Does this look right? SC impeller
    By JayG in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-17-2007, 06:15 PM
  5. Does this look right?
    By MikeB in forum 4-Tec Performance
    Replies: 16
    Last Post: 04-11-2007, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •