Results 1 to 4 of 4
  1. #1
    mmiller2197's Avatar
    Join Date
    Sep 2014
    Location
    Pittsburgh, PA
    Posts
    2

    Ski Module Installed But Not Working on 2012 GTI SE 130!!

    Hello Everyone. I am new to the forum and am sorry if this issue has been addressed in the past. I tried to make sure it wasn't.

    So here is my issue. I installed the SeaDoo Ski Module (Part #295100432) on my 2012 GTI SE 130. I went through the entire install from plugging into the diagnostic connector to plugging everything into the fuse box. I reconnected my battery and with the normal key installed went through the menu and nothing appeared. When my gauges first come on you can see the SKI Mode graphic on the screen but nothing shows up in the menu. I was not sure if after the install you need a dealer to activate it or whether it would just show up. According to the directions it should just recognize the module and show up. My thought is one of two things it either is a bad module, or the system needs to be activated by the dealer. Any thoughts on what to do or look for? Thanks everyone in advance.


  2. #2
    myown1manarmy's Avatar
    Join Date
    May 2012
    Location
    Noblesville, Indiana, United States
    Posts
    164
    +1
    13
    Should not need to be activated..double check you wiring

  3. #3
    mmiller2197's Avatar
    Join Date
    Sep 2014
    Location
    Pittsburgh, PA
    Posts
    2
    Thanks myown1manarmy,
    I have checked it many times but will check it again. It seems to be hooked up according to the directions. I am thinking about ordering another module and seeing if it works. Thanks again and let you know what I find out.

  4. #4
    john07ex's Avatar
    Join Date
    Jul 2007
    Location
    Orlando, Fl
    Posts
    478
    +1
    27
    any update?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speedometer/tachometer on 2014 GTI SE 130
    By mist3rburnz in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-25-2014, 09:36 AM
  2. Selling my 2012 GTI SE 130
    By taz01 in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 12-08-2013, 08:17 AM
  3. Fault Code C2 100 on New 2012 GTI SE 130
    By Scorps in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-12-2012, 06:39 PM
  4. How to blow exhaust out on 2012 GTI SE 130
    By taz01 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-09-2012, 04:50 PM
  5. 2012 GTI SE 130 Display Settings
    By Nicholas Campbell in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-13-2012, 07:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •