Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19

    2014 RXP-X not sure if I have a problem

    Ski seams to run fine. Has 48 hours on it. I noticed that if I hold it wide open I get 8100 rpm give or take a few do to choppy water and full boost at 70mph on the gauge. The problem is when I hold it for a bit it drops to 69mph I loose 1 to 2 bars of boost and 7940-7960. But if I lift off the thotte and pin it again she builds back up to 8100 ect. And then loose a bit again. Do I have a issue?

    Ski is stock. Changed the oil and plugs at 47 hrs but I noticed this before the oil change.
    Thanks


  2. #2
    lt1pwr's Avatar
    Join Date
    Jul 2012
    Location
    Lake Wedowee, AL
    Posts
    300
    +1
    40
    You don't have an issue. This is the same thing I experienced too.

    The dealer told me the limiter is doing that. The ski has a boost limiter, speed limiter and RPM limiter. When you get in the range of one of these limiters, it will back the RPM's / boost down and then slowly build back up and then repeat again.

    Someone else on here might chime in and be able to give you a more detailed explanation, but that's how it was explained to me.

  3. #3
    Yes, no worries - IT1pwr is exactly right. The speed limiter will close the throttle plate when the set speed is met or exceeded for a length of time.

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Time for a reflash to get rid of the limiters

  5. +1 by:


  6. #5
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    Thanks guys... yeah I figured this is the case. Just never noticed.

  7. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by ryandi2 View Post
    Thanks guys... yeah I figured this is the case. Just never noticed.
    Probably turning up a bit more with the cooler temperatures. May not have turned up that high in the warmer summer air.

  8. #7
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    I don't think I was holding her pinned for as long and watching the gauges

  9. #8
    Evolol's Avatar
    Join Date
    May 2014
    Location
    Masshole
    Posts
    137
    +1
    2
    Im sure ryandi2 wants to know the same question. . Whats the best way to remove the rev, speed, boost limiters? Riva S.C.O.M?, R&D Boost Box?, or vetch? Cheapest way possible?

  10. #9
    Quote Originally Posted by Evolol View Post
    Im sure ryandi2 wants to know the same question. . Whats the best way to remove the rev, speed, boost limiters? Riva S.C.O.M?, R&D Boost Box?, or vetch? Cheapest way possible?
    SCOM and Boost Box are SCAM! They don't work at all and waste of money. Save up for V-TECH KIT or RD REFLASH! I prefer V-Tech since you can restore back to stock for warranty work or etc.

  11. #10
    Evolol's Avatar
    Join Date
    May 2014
    Location
    Masshole
    Posts
    137
    +1
    2
    Quote Originally Posted by Jackmcd View Post
    Quote Originally Posted by Evolol View Post
    Im sure ryandi2 wants to know the same question. . Whats the best way to remove the rev, speed, boost limiters? Riva S.C.O.M?, R&D Boost Box?, or vetch? Cheapest way possible?
    SCOM and Boost Box are SCAM! They don't work at all and waste of money. Save up for V-TECH KIT or RD REFLASH! I prefer V-Tech since you can restore back to stock for warranty work or etc.

    Price for VTech kit? Best place to purchase? how easy is it to turn back to factory?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. not sure if this is ecu problem
    By kerry gross in forum Sea Doo ECU Support
    Replies: 5
    Last Post: 08-23-2016, 04:39 PM
  2. Not sure If you have seen this boat. But pretty cool
    By 20 feet Boy in forum Videos & Pictures
    Replies: 6
    Last Post: 12-27-2012, 11:09 AM
  3. Not sure if i have ever thanked everyone!!!
    By MR MAC in forum Open Discussion
    Replies: 12
    Last Post: 02-23-2011, 11:49 AM
  4. Not sure if this is a dumb ? or not!
    By NeverEndn in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-14-2006, 08:08 AM
  5. Not sure if I've ever posted this in here or not.
    By BertInTexas in forum 4-Tec Performance
    Replies: 0
    Last Post: 04-01-2006, 04:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •