Results 1 to 4 of 4
  1. #1
    Yamaha tow boat RIDEALLDAY's Avatar
    Join Date
    Feb 2006
    Location
    Texas
    Posts
    1,447

    97 GTI surging at 20mph

    My friends GTI starts,idles and runs fine up to 20-25mph then falls off on rpm then picks up rpm, up-down-up-down. It's like it runs out of fuel.
    Ok, I pulled the fuel screen up front and it was clogged with rust or dirt from some bad gas. I bought a new one, now I think some of that crap got to the carb.
    Any easy solutions guys? Thanks, Todd

    Ps- the boat has been running fine until now.


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,627
    +1
    806
    mine trys to cut out every time i hit it from idle to 15mph. i also get too much smoke at startup and some milky solution at the bottom of the hull.

    if you have any of those symptoms then you might want to check your fuel timing/carb adjustment.

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,397
    +1
    2,524
    Did you try changing the spark plugs?

  4. #4
    Yamaha tow boat RIDEALLDAY's Avatar
    Join Date
    Feb 2006
    Location
    Texas
    Posts
    1,447
    They have 2 rides on them. When you ride it you wouldn't know threre was a problem until 20-25, it's quick out of the hole. It feels like the high speed circuit in the carb is clogged. It really seems like a fuel problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 GTI engine surges at stedy speed
    By jeep2001 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-29-2012, 11:02 PM
  2. 1997 gti surging at wot
    By 4pinwink in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-16-2012, 11:57 AM
  3. Looking at a good used 97 GTI
    By 3dfever in forum 2-Stroke Performance
    Replies: 0
    Last Post: 02-26-2012, 07:43 AM
  4. 97 GTI carbon ring
    By code322 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-08-2007, 06:18 AM
  5. Surging at idle w/ RR whell and 42's? Normal?
    By Water4fire in forum 4-Tec Performance
    Replies: 25
    Last Post: 04-10-2007, 07:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •