Results 1 to 4 of 4

Thread: 1994 750 ss

  1. #1

    1994 750 ss

    Having an issue with the power while the PWC is in the water. The motor runs great when I turn it before I get in the water. When I get into the water it runs good for a little bit but then it bogs down. After 15 minutes it looses all power almost, I can coast it back to shore. I'm not sure if these engines run like a boat and suck up water to cool the motor down but is that an option on this type of PWC? I notice on the parts it has a water muffle option, but I wasn't sure if that was a big thing to look at for this reason or what.

    Any help would be appreciated...slowly starting to happen to my 93 xi as well. Starting to think there is a crack somewhere on the water intake if its like a boat, but didnt want to take it apart if it isn't worth looking at


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    Sounds like you're not venting the fuel tank properly. Try loosening the fuel cap a little, but be careful not to get water in it.

    Might also be an exhaust leak filling the engine compartment with fumes, but I don't think it would run that long.

  3. #3
    Quote Originally Posted by steve45 View Post
    Sounds like you're not venting the fuel tank properly. Try loosening the fuel cap a little, but be careful not to get water in it.

    Might also be an exhaust leak filling the engine compartment with fumes, but I don't think it would run that long.
    How do u fix the problem of the fuel tank to vent? I dont want to loosen the cap and chance water getting in the fuel...

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    OK, try riding it until it acts up, then stop and loosen/tighten the cap and ride it again. If the problem goes away temporarily, you have a venting problem. (Hell, half of these things have cracks in the fuel caps).

    There is a vent line that goes through a valve and exits out the handlebar pad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3 vs. 5 blade impeller 1994 750 ss xi
    By demian5 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 18
    Last Post: 08-03-2017, 10:40 PM
  2. 1994 750 ss xi no gauges or trim
    By demian5 in forum Kawasaki How To & FAQs
    Replies: 14
    Last Post: 09-13-2012, 12:17 AM
  3. 1994 750 ss xi excessive oil consumption
    By demian5 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-03-2012, 10:07 PM
  4. 1994 750 SS hard start after sitting
    By Yahooligan in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 01-16-2012, 11:30 AM
  5. 1994 750 SS Fuel Filter?
    By atc250r in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 08-26-2008, 08:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •