Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    RXPDAVID's Avatar
    Join Date
    Apr 2005
    Location
    West Tennessee
    Posts
    403

    Please lOOk and tell me what you think happened!

    This is from my wife's 2006 RXT. It has around 90 hours on it. Engine locked up so I pulled pump first (no problem there), then I pulled the supercharger and this is what I found.
    What do you think caused it? Flywheel bolts??, SC bearing??, Starter Bendix??
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_3805.jpg 
Views:	354 
Size:	68.7 KB 
ID:	343606  


  2. #2
    Rt-HemiBoY's Avatar
    Join Date
    Mar 2010
    Location
    HiAleAH-MiAMi--FL
    Posts
    1,315
    +1
    24
    Many factor could have caused that is that the original charger of the ski?? Even if it was at 90 hours shod have done a rebuilt also maybe overtignen the nut with shaft.

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by RXPDAVID View Post
    This is from my wife's 2006 RXT. It has around 90 hours on it. Engine locked up so I pulled pump first (no problem there), then I pulled the supercharger and this is what I found.
    What do you think caused it? Flywheel bolts??, SC bearing??, Starter Bendix??

    Supercharger bearing failure. This is why these things really should be rebuilt every 100 hours or every 2 years whichever occurs first... those bearing cages get brittle over time.
    If you look in the supercharger outlet I'm sure you will find some gray dust from the impeller grinding into the front housing... if this has happened you will need to replace the supercharger. I do have them discounted in the forums online store.
    http://www.4-tecperformance.com/inde...oducts_id=1231

  4. #4
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    very surprising it broke the shaft, i know my ceramic bearing went and the SC wheel just locked up and the SC gear just spun freely, maybe this clutch was setup too tightly and just snapped the shaft

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by meeper View Post
    very surprising it broke the shaft, i know my ceramic bearing went and the SC wheel just locked up and the SC gear just spun freely, maybe this clutch was setup too tightly and just snapped the shaft
    I see this too frequently. Supercharger is spinning at high RPM. Bearing fails. Shaft locks sideways in supercharger housing causing supercharger impeller to grind into front housing causing an abrupt stop. Abrupt stop can sometimes cause supercharger shaft to snap off.

  6. #6
    RXPDAVID's Avatar
    Join Date
    Apr 2005
    Location
    West Tennessee
    Posts
    403
    This is not the original SC. It had metal washers. There is no dust and the bearings spin freely with no play. I know it is hard to see from the picture but it looks like something internally hit the shaft and snapped it off. I am leaning toward flywheel bolts. Looks like I need to pull the engine.

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by RXPDAVID View Post
    This is not the original SC. It had metal washers. There is no dust and the bearings spin freely with no play. I know it is hard to see from the picture but it looks like something internally hit the shaft and snapped it off. I am leaning toward flywheel bolts. Looks like I need to pull the engine.
    In that case your supercharger is definitely rebuildable.
    The bearing failure more than likely happened when the supercharger shaft was forced upward.

    Could be the flywheel bolts gave way

    Let us know what you find.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_3805.jpg 
Views:	141 
Size:	45.6 KB 
ID:	343630  

  8. +1 by:


  9. #8

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    I think someone f'd the charger up when the replacement washers were added. I purchased a rebuilt charger here about 1.5 yrs. ago-- 3 hours on the "fresh rebuild". When I took it out of the box and spun the wheel, I could see the gear wobbling-- set it up in the holder, took off the nut and spring washers and then put an indicator on the shaft and found that the shaft was bent .004".

    If the person doesn't know how to work with attention to detail with these chargers, they should put down their hammers and get it done by someone that knows how to do it correctly.

  10. #9
    RXPDAVID's Avatar
    Join Date
    Apr 2005
    Location
    West Tennessee
    Posts
    403
    I went ahead and opened up the SC and found where the impeller and housing had been having considerable contact just as Jerry said (as usual he is right). How may ball bearing should there be I am only counting 7. Does that mean I have one down in the engine. Am I still going to have to pull the engine?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_3806.jpg 
Views:	107 
Size:	121.0 KB 
ID:	343642   Click image for larger version. 

Name:	IMG_3807.jpg 
Views:	108 
Size:	101.3 KB 
ID:	343643  

  11. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by RXPDAVID View Post
    I went ahead and opened up the SC and found where the impeller and housing had been having considerable contact just as Jerry said (as usual he is right). How may ball bearing should there be I am only counting 7. Does that mean I have one down in the engine. Am I still going to have to pull the engine?
    your in luck! all 7 bearings are there. You can compare your bad bearing to the bearing picture in my store
    http://www.4-tecperformance.com/inde...oducts_id=2293

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: 07-19-2011, 09:15 PM
  2. Looking at 2 "new" jet skis, tell me what you think.
    By Firefighterarcher in forum Open Discussion
    Replies: 6
    Last Post: 06-27-2011, 07:50 PM
  3. Piston wash: Tell me what you think?
    By delagem in forum Polaris Open Discussion
    Replies: 23
    Last Post: 07-28-2007, 06:14 PM
  4. please have a look and tell me what you think
    By Hydrotherapy in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 12-29-2006, 09:53 AM
  5. My ski is on ebay, tell me what you think of my listing...
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-14-2006, 09:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •