Results 1 to 4 of 4
  1. #1

    2004 GP800R No powervalve movement

    Haven't ridden my ski since June, decided to dust it off today. Runs fine, but I noticed after I shut it down (this was on the trailer in my driveway) the powervalve didn't cycle like it used to shortly the motor was killed. Cranked it back up and sure enough the powervalve didn't move when throttled. If I take it out of its idle position with a pair of plyers and crank it up, it moves back by itself, so its def getting power. Any idea whats going on here? Is there a way to test that servo?


    Thanks,
    Nate
    Last edited by 800n; 10-07-2014 at 06:03 PM.


  2. #2
    Found the procedure online, tested it and it looks like the servo is toast. Tried the same procedure on my XLT800 and the servo moved and reset as it should. To ebay I go.

  3. #3
    How do you know if the powers valves arnt working? I know there is a accelleration problem with my ski , 1999 xl1200 what should I do to test the valves? top speed i can get is about 50

  4. #4
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Houston, TX
    Posts
    570
    +1
    51
    Quote Originally Posted by Extrnoa View Post
    How do you know if the powers valves arnt working? I know there is a accelleration problem with my ski , 1999 xl1200 what should I do to test the valves? top speed i can get is about 50
    Start the ski, then turn off. The PV servo should cycle within a few seconds. If it does not, then the servo is probably bad.

    As these skis age, the PV servo is probably the #1 electrical part that I have seen go out. Very common. Good to keep a spare on-hand, as well as a starter relay.

    -Greg

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2004 gp800r 2400.00
    By ALOHR in forum Yamaha Classifieds
    Replies: 0
    Last Post: 10-25-2009, 08:19 PM
  2. Looking at buying a 2004 rxp no key...
    By spinyard in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-28-2009, 01:13 PM
  3. gp800r no idle and rough
    By gp8r in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 02-02-2008, 09:40 AM
  4. need help!! 2004 rxp no beep no crank
    By shannon in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-06-2007, 01:10 AM
  5. buying a GPR.... powervalves or no powervalves???
    By TJBrad04 in forum Yamaha PWC Performance (2-stroke)
    Replies: 28
    Last Post: 01-19-2007, 02:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •