Results 1 to 10 of 10
  1. #1
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1

    2012 GTR electrical problems

    Long story short. Ski Sunk in salt, got all the water out. Now has some electrical problems, gauges keep going on and off. I'll hit the start button and it turns over couple seconds later it powers down. Then I'll hit the start again and they come back up. I cleaned out all the connectors and used dielectric grease. What's next step?


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Did you verify that all of the wires and pins in those connectors are clean and not green?? Are any of the wires broken??

    I had a Can AM Outlander XMR 1000 at the shop and he took it deep in the mud/water and 3 of the connectors had broken wires from the corrosion in them.

  3. +1 by:


  4. #3
    Change the main relay in the fuse box, if you had water in it.

  5. +1 by:


  6. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Sorry to say this but that ski is doomed for ghostly problems in the future.
    I've never had a sunken salt water ski be 100% for too long.

    Hopefully you have better luck than me!!!

  7. #5
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    Quote Originally Posted by Tiny View Post
    Did you verify that all of the wires and pins in those connectors are clean and not green?? Are any of the wires broken??

    I had a Can AM Outlander XMR 1000 at the shop and he took it deep in the mud/water and 3 of the connectors had broken wires from the corrosion in them.
    Per my brother he said all the connectors were cleaned. I have not looked at them my self. He said connectors and fuse box had no water in them.

  8. #6
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    Quote Originally Posted by RXP6 View Post
    Change the main relay in the fuse box, if you had water in it.
    My brother said there was no water in there.

  9. #7
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    Quote Originally Posted by wotxxxsd View Post
    Sorry to say this but that ski is doomed for ghostly problems in the future.
    I've never had a sunken salt water ski be 100% for too long.

    Hopefully you have better luck than me!!!
    I'm definitely changing out head with new rocker arms. Will tear it completely apart this week

  10. #8
    How did it sink?

  11. #9
    liquidmilitia.com rxp127's Avatar
    Join Date
    Aug 2006
    Location
    SO*CAL
    Posts
    923
    +1
    1
    Quote Originally Posted by Resq View Post
    How did it sink?
    I bought like this. But guy said he had it ima marina. Sunk over night. When I brought it home took resinator off and it was cracked.

  12. #10

    Join Date
    Oct 2012
    Location
    Australia
    Posts
    100
    +1
    7
    Check battery and soory to say all your cables are going to be toast. Salt water will leach into each cable and over time turn them green decreasing the electrical properties.
    The fuse box is rated for splash protection not immersion.
    Pull each fuse and put it back. Replace relays a must.
    Pull apart every connection u can find and check.
    Then leave it out in the sun for a few days good luck

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GSX Ltd Electrical problem - It died!
    By tomgtv in forum 2-Stroke Performance
    Replies: 12
    Last Post: 03-10-2007, 10:03 AM
  2. Strange electrical problem -- instrument cluster going crazy
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-06-2006, 05:23 AM
  3. '04 GTX SC electrical problem
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-01-2006, 06:49 PM
  4. Help me solve this electrical problem
    By MPower in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-26-2006, 09:05 PM
  5. Electrical Problems
    By Red Devil in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-31-2005, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •