Results 1 to 5 of 5
  1. #1
    EROD Palm Beach Punisher's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    380
    +1
    3

    Engine turns w/ plus off but not with plugs on. " help"

    I just rebuilt the motor when it was on the bench it spun fine. We installed the motor and and the engine wouldn't turn over. we pulled the plugs and the engine turns fine.
    1. we replaced the battery
    2. we replaced the cable going to the starter and the starter.
    3. we jumped the ski with a car and it tries to turn over but it doesn't.
    4. checked the grounds and all were good .
    5. ran a ground to the block and nothing.
    please help


  2. #2
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    first, never ever ever attach a ski to a running car. It sounds like your timing is off and you're not releasing compression. Put a 17mm socket on the supercharger nut and spin it by ratchet. If it turns over fairly easily then your starter is toast.

  3. #3
    EROD Palm Beach Punisher's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    380
    +1
    3
    I'S on a turbo ski

  4. #4
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    hmmmm take the valve cover off and turn it by the came gear

  5. #5
    EROD Palm Beach Punisher's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    380
    +1
    3
    getting off from work and will let you know thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with engine turning but not starting
    By Peter B in forum 4-Tec Performance
    Replies: 7
    Last Post: 12-23-2012, 04:37 AM
  2. Replies: 11
    Last Post: 08-07-2011, 11:52 AM
  3. Engine runs strong in driveway on hose, but not at river...
    By jls7707 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 08-05-2010, 10:53 PM
  4. should engine turn over with no CDI
    By Slipknotanfitch9 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-22-2010, 05:27 PM
  5. Engine turns over but won't iddle
    By exodo90 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 07-15-2007, 12:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •