Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Aug 2009
    Location
    CA
    Posts
    237

    Need opinion on metal in oil filter?

    k
    Last edited by bryanw80; 01-30-2015 at 12:53 AM.


  2. #2

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    I chipped flywheel teeth and marred up both oil pumps and I had less filings in my oil filter area. You got big problems.

  3. #3
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Clean it up if You changing Your oil with good oil move on. All motors will produce little metal shavings from time and age. If It has been properly flushed (water evacuated) and proper oil and filter ( clean) installed with level being right ride on!!!

    Particles/ shavings fine chunks and pieces obviously no good. In conclusion if Your producing metal to be concerned, You will know by performance and sound!!!

  4. +1 by:


  5. #4

    Join Date
    Aug 2009
    Location
    CA
    Posts
    237
    Really, that bad? I didn't think there was that much in the filter. I am going to cut it open to look at it better. If it is that bad how has it been running so perfect for the last 6 hours? Any ideas or suggestions?
    Quote Originally Posted by Speed_Freak_039A View Post
    I chipped flywheel teeth and marred up both oil pumps and I had less filings in my oil filter area. You got big problems.

  6. #5

    Join Date
    Aug 2009
    Location
    CA
    Posts
    237
    So you think it should be ok? Should I do or check anything else? I did clean it all out and put in a new k&n oil filter and valvoline 10w-40 motorcycle oil.
    Quote Originally Posted by shrabber View Post
    Clean it up if You changing Your oil with good oil move on. All motors will produce little metal shavings from time and age. If It has been properly flushed (water evacuated) and proper oil and filter ( clean) installed with level being right ride on!!!

  7. #6
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    If you chipped a flywheel it will get caught up in Your oil pump screens. Weight and size will not get those chunks to flow up through the pto/oil filter housing

    Then again Your explanation did not state a hydro lock or anything associated with a stripped flywheel gear

    RIDE ON!!!!!

  8. #7
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Quote Originally Posted by bryanw80 View Post
    So you think it should be ok? Should I do or check anything else? I did clean it all out and put in a new k&n oil filter and valvoline 10w-40 motorcycle oil.
    Quote Originally Posted by shrabber View Post
    Clean it up if You changing Your oil with good oil move on. All motors will produce little metal shavings from time and age. If It has been properly flushed (water evacuated) and proper oil and filter ( clean) installed with level being right ride on!!!
    Yes, based on Your post... You flushed and changed your oil a few times and boiled the water out.

    Valvoline Motorcyclycle oil is fine!!! Oil level in middle ride and enjoy. Keep a eye on your oil

    To to make a You feel better I changed oil and filter on a 2014 chevy truck with 6k miles Yesterday and there was some fine metallic flakes.

    Very common!!!

  9. #8
    Could it not just be salt deposits if you sunk the ski? Like said above engines do produce small metal shavings from time to time that's why with my supra I installed a magnetic sump plug so it would catch any if any, and stop them getting sucked back up the pickup and going back around the system.

  10. #9
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304
    FWIW, I'm pretty sure I've had some small - miniscule flakes like you show every time I've changed the oil (two: '06 RXT). That's now 300 hours on each ski and going on 8 years...

  11. #10
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Ride more worry less, the filter would not be there if there if there were no particles to filter. I would not be concerned.

  12. +1 by:


Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 RXP Metal in Oil Filter
    By jsnacker in forum 4-Tec Performance
    Replies: 24
    Last Post: 08-16-2015, 09:09 PM
  2. Metal In oil filter!! What to do now...
    By ctdarnell in forum Sea Doo Open Discussion
    Replies: 24
    Last Post: 07-31-2012, 11:46 PM
  3. metal shavings in oil filter! Advice?
    By INDY27 in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-08-2012, 07:13 AM
  4. What is your opinion on using this oil in an XL760?
    By shawnmd in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 08-30-2010, 09:13 AM
  5. metal shavings in oil filter, what to do?
    By RXPteamtimebomb in forum 4-Tec Performance
    Replies: 12
    Last Post: 11-03-2009, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •