Results 1 to 2 of 2

Thread: Rust questions

  1. #1

    Rust questions

    Hi all,

    27 hrs on the spark now in under 2 months of riding and I'm beginning to see signs of rust in a few places.

    The prop shaft is getting quite a few rust spots on it, the steering column connection where the knee protectors are is also getting rust.

    I wash it down religiously after every ride and look after it extremely well. See pic below for the prop shaft.

    Is this anything to be worried about? I plan on doing well over 100+ hrs between now and end of summer and just want to make sure the spark is up to it..

  2. #2
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Melbourne, Australia
    Nothing to worry about, keep riding

    The steering I'd keep an eye on.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  3. Oil Level question , this thing mixes me up :(
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2005, 10:03 AM
  4. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts