Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    2004 kawasaki ultra 150 battery wiring problem

    HELP!


    Any kawasaki ultra 150 owners


    I have a 04 ultra 150


    Just bought it , previous owner was changing the battery and got mixed up on what goes where. Obviously big black terminal goes to ground. ( which runs to the engine block ) And the red terminal goes to positive (which runs to a small grey box behind the battery) . They weren't swapped like put on the battery backwards. They were put on correct. But there was a little single wire (looked black) that Supposively went to battery. They were unsure of where, so they put it where they guess and it melted the entire wire and caused ski to no longer start.


    I traced wire back. It runs to a grey electrical box behind battery. Same box that the positive terminal runs too.

    I have new wire ready to install


    BUT where does this wire run to?


    Can anyone send or post a pic of there battery area so I can see what all wiring goes where.

    Does this wire go to a battery terminal or does it go somewhere else


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    The schematic shows that it goes to the smart steering system actuator.

  3. #3
    Quote Originally Posted by steve45 View Post
    The schematic shows that it goes to the smart steering system actuator.
    Its a small wire that runs to the grey electric box behind the battery the same box that the positive cable runs to. This wire runs through the rubber boot on the top of the box and then runs to a screw inside the box that has other wires also with eye hooks that all get screwed down.

    is that correct?

    And where does it go?

    anyway to send me what your looking at?

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    I'm just looking at the electrical schematic in the service manual. I don't have the smart steering on my 'Ski, so I can't take any pics.

    Send me a PM with your email address and I'll send you the pages from the manual.

  5. #5
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    I don't know why I waste my time trying to help idiots like this. I made JPEG images of 4 pages for this guy and no response.

  6. +1 by:


  7. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,529
    +1
    1,279
    I somehow doubt there was a previous owner involved here....

    I'll be honest, I've cut back quite a bit helping low count posters past some basic pointing to information here and on the web.

    I would have told him to get a manual and good luck..as there isn't much of a chance of fixing a wire problem without the proper schematic for that year ski.

    He likely opened the harness and found he had a much larger problem then a single burnt wire.

    Let's see if any redemption for him is in the cards.....

  8. #7
    wakejunkie's Avatar
    Join Date
    Jan 2012
    Location
    SML, VA and RDU
    Posts
    298
    +1
    19
    I got a weird issue with my 04 ultra that keeps killing batteries. Somewhere there is something drawing current on the battery when the ski is off and orange ignition switch off. Also when the ski is idling the battery light flashes but when cruising no lights. Not sure if that is an issue or just a result of the dying battery. So now I have to get a new battery and put it in the ski then start disconnecting electrical plugs until the current draw stops to find the culprit. Anybody got any suggestions that might help start the search?

  9. #8
    Check your rectifier

  10. #9
    wakejunkie's Avatar
    Join Date
    Jan 2012
    Location
    SML, VA and RDU
    Posts
    298
    +1
    19
    Any special process to check the rectifier? Amps output or volts output or resistance?

  11. #10
    Do you have a manual? Follow the diagnostic

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 ultra 150 battery wiring problem
    By Crodgers14 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 01-28-2015, 04:45 PM
  2. Kawasaki ultra 150 engine mounts problem.
    By orest100 in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 05-13-2011, 05:40 PM
  3. FS 2004 Kawasaki Ultra 150 (skiworx 1.5) 24 Hours $4000
    By Skiworx in forum Kawasaki Skis
    Replies: 0
    Last Post: 10-15-2010, 11:26 AM
  4. FS Parting out 2004 Kawasaki Ultra 150 99-04 / MAKE OFFER !!
    By kaboom3757 in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 09-06-2010, 09:26 AM
  5. FS FS: Parting out 2004 Kawasaki Ultra 150 99-04 / Pics & Prices
    By kaboom3757 in forum Kawasaki Classifieds
    Replies: 5
    Last Post: 07-28-2010, 07:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •