Results 1 to 7 of 7
  1. #1

    Found this hose disconnected.

    Hi Guys,

    After some advice on a second hand RXP X 260 I just picked up. Was having a look around in the engine bay and found an oil breather hose disconnected. As seen in the pic. The end where the arrow is pointing was hanging loose.

    Click image for larger version. 

Name:	Screen Shot 2014-11-26 at 20.38.13.png 
Views:	159 
Size:	316.0 KB 
ID:	347365

    Question is, I obviously don't know how long its been like this, so is there any possible damage occurred or anything else I should check further?

  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Davison, Mi
    the only damage could come from something getting in the intake hose
    even water is not good for the motor and enough can seriously damage the motor

  3. #3
    Sanfish's Avatar
    Join Date
    Jun 2014
    S/E Florida
    If it were mine, I would remove large elbow that attaches to SC and with a light and mirror, look in to view the SC wheel. If water had been getting in there over time, the impeller will look crusty. That hose fits onto the fitting pretty tight so I can't see how this just popped-off.

    Does it have the stock airbox above the gas tank and does it appear untouched?
    How many hours on ski and did owner say if the SC was rebuilt?

  4. #4
    Yeah all the air box etc is stock.

    it does not take that much force to remove the plastic bung from the rubber elbow.

    will take it off at the weekend and have a look at the sc wheel, presume it should look clean and not corroded in anyway?

    i doubt from the height of the hole etc much water would have ever entered the engine.

  5. #5
    R-Doo's Avatar
    Join Date
    Sep 2006
    My bet is someone took it off while they were checking out the SC. Just forgot to put it back on. Maybe someone looking before they bought?

  6. #6
    Yanksfan's Avatar
    Join Date
    Apr 2012
    Be glad it was that, I also recently got my PX and while I was cleaning the engine compartment the left bailer hose that is right after the IBR module came off, What a PITA to put a clamp on that sucker...

  7. #7
    Tucka's Avatar
    Join Date
    Jun 2012
    mount warrigal NSW Australia
    Same thing happened to me , where it fits into the big hose it had softened. The bigger hose was replaced and doesnt pop out anymore.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can this hose cause a problem?
    By GeoRXT in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-13-2007, 10:01 PM
  2. Found this on the USCG Recall site
    By TheBaron in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-05-2007, 09:32 AM
  3. Does This Hose Actually Make Any Difference w/Noise?
    By BoostedH23a1 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-11-2007, 12:40 PM
  4. Nice 'ski; he shoulda found this forum earlier
    By J-ME in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 01-22-2007, 02:25 PM
  5. Just found this site
    By Pettee in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 10-19-2005, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts