Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207

    Anyone else have trouble communicating with Skat trak?

    One of the skat trak props in one of our turbo skis decided to strip out its teeth on the spline...

    I've sent Glenn and their general inquiry email a few messages and have had zero response, I tried calling and also could not get a call back?

    All I needed was the inside spline part inserts on the props...

    I had to use an OEM spline in the end to make their props work again, is there an issue with their email system?

    I might have to go back to solas if its this hard to develop a working product.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    When did you first send the email?

    Thanksgiving holiday in the US this week, especially after Wednesday. Many places are closed Thursday and Friday, sometimes reduced hours or minimal staff the whole week.

  3. #3
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    Whenever I send an email it typically takes a buisness day for a response but michelle is pretty consistent.... probably on vacation

  4. #4
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Quote Originally Posted by GasResearch-VT.SE View Post
    One of the skat trak props in one of our turbo skis decided to strip out its teeth on the spline...

    I've sent Glenn and their general inquiry email a few messages and have had zero response, I tried calling and also could not get a call back?

    All I needed was the inside spline part inserts on the props...

    I had to use an OEM spline in the end to make their props work again, is there an issue with their email system?

    I might have to go back to solas if its this hard to develop a working product.

    Totally off topic, but now you know how I felt when I waited 1 WEEK for a response from Vtech.......

  5. +1 by:


  6. #5
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Well this is going back about 3-4 weeks no with no reply.

  7. #6
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    That is a little odd.....

  8. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by GasResearch-VT.SE View Post
    Well this is going back about 3-4 weeks no with no reply.
    What email address are you sending to?

  9. #8
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Glenn's direct one and the [email protected]

  10. #9
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Sent them 1 last email... Sad that I had to resort to the forum for something that should be trivial

  11. #10
    Banned User
    Join Date
    May 2006
    Posts
    1,329
    +1
    152
    I have been dealing with them for years and never had that kind of experience. Gleen is nearly always there.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is anyone else having a problem with the search feature?
    By outonalimb in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-05-2010, 02:25 PM
  2. Replies: 1
    Last Post: 08-31-2009, 12:33 PM
  3. any body else having trouble displaying links?
    By jpt7779 in forum 4-Tec Performance
    Replies: 1
    Last Post: 01-07-2009, 04:34 PM
  4. Anyone else having Hotmail issues
    By 785xp in forum Open Discussion
    Replies: 3
    Last Post: 02-24-2008, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •