Results 1 to 7 of 7
  1. #1

    2001 GPR Riva Stage 3 Kit Issues

    Buddy has a 01 GPR 1200 with the stage three kit from riva. boat hasn't ran in 5 years. When this boat quit running it was blowing the 20amp fuse in the box. with the riva ecu. fast forward to now I get a stock ecu and a protect ecu, now the boat will turn over for 20 seconds or so then the alarm goes off constant along with the red light and the thermometer indicator icon is flashing but no spark. does anyone have a clue on what the problem could be? Thanks


  2. #2
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    The lower exhaust sensor either bad or disconnected.

  3. #3
    isn't that removed or a loop put on it when the triples are installed? Sorry for the confusion im not a Yamaha guy just trying to help a buddy out thanks

  4. #4
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    If you have the stock CDI on it you need the lower sensor plugged in and taped to the harness or the correct resistor installed. you will also need the chip for the upper sensor or the resistor for it also. I am running triples with an Advent CDI and have the chip for the upper and the lower sensor plugged in and taped to the wire harness.

  5. #5
    alright there is nothing plugged into either of those so that must be my issue. I know I can buy a new lower sensor. Where can I get the chip for the upper sensor? thanks

    Also it is the sensor that is around $270 that is the lower one correct? thanks

  6. #6
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    you can order the chip from Riva. you might be better off getting a used lower sensor for the money. I cant remember if you can use a resistor or not on the lower but i think you can. ill try to look it up and see what size. you can put a post in the classified section to get a used one. ill check my price on the new lower sensor also.

  7. #7
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    PM sent

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. be carefull riva stage 2 kits
    By two2curupt in forum 4-Tec Performance
    Replies: 50
    Last Post: 09-16-2005, 11:24 AM
  2. Riva stage 2 kit
    By Jaye in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-30-2005, 09:56 PM
  3. Where should trim be with riva stage one kit
    By macattack in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-30-2005, 09:46 AM
  4. riva stage 1 kit problems
    By macattack in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-28-2005, 05:08 PM
  5. Riva Stage 1 kit (how long does it take to install)
    By macattack in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-20-2005, 04:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •