Results 1 to 3 of 3
  1. #1

    Join Date
    Oct 2012

    GP1300r dash display went blank

    Was out on the ski today and everything was working fine all day. i then turned the ski off for a minute and then jumped back on and the dash display was blank and wouldnt come back for the rest of the day. is there a fuse for the dash or something i should check to get it back on again or do i need to replace the dash? Its a 2006 GP1300r. thanks
    Last edited by saro13b; 12-22-2014 at 05:53 AM. Reason: forgot to write dash in the title

  2. #2
    mudslanger's Avatar
    Join Date
    Jul 2010
    Huntsville Al
    It sounds like a bad wire connection. i would check and clean all the connections that would unplug.

  3. #3

    Join Date
    Oct 2012
    went through all the wiring from the dash to the connection and found that somehow the red wire had been cut. Not sure how that wire can get cut while im out on the water but problem solved. thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP1300r dash Display went blank
    By saro13b in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 12-21-2014, 03:27 AM
  2. 2003 gp1300r display
    By mitchf42 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 10-15-2013, 02:16 PM
  3. FS - Parts GP1300R DISPLAY UNIT Australia
    By 1200Jet in forum Yamaha Classifieds
    Replies: 1
    Last Post: 02-22-2013, 01:23 AM
  4. WTB 03-04 gp1300r display
    By ctct2118 in forum Yamaha Classifieds
    Replies: 2
    Last Post: 09-15-2011, 05:14 AM
  5. FS----03 gp1300r display
    By KEYZBUM in forum Yamaha Classifieds
    Replies: 1
    Last Post: 06-05-2009, 06:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts