Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    Apr 2012
    Location
    Troy, MO
    Posts
    496
    +1
    70

    2012 RXP-X 260..carbon seal and pump seal... Quality control? Check your carbon seal!

    I always say that my 12' P-X is best thing that I have ever spent my money on, but this is RIDICULOUS, lol.

    77 hours on the ski, the pump has never been off, and it is 100% bone stock. I never really had any cavitation or water in the hull.....last time I had it out, it was cavitating a bit, and there was a little water in the hull, but it was in ROUGH water, and it was in the water for about 48 hours straight, so I didn't think much of it. Turn out, I am lucky that it didn't sink!

    I must have the engine alignment issue that many people had with the 2012's, and also the pump seal was pinched in the pump shoe....It's a miracle that it hooked up as good as it did.

    I about shit when I saw what looked like brake dust in the hull....I knew exactly what it was.


    Is this a joke? Look at the seal!


    At least the impeller and wear ring look decent for 77 hours.


    Now the fun stuff....








    I guess the engine will be getting aligned and a new pump seal. Also doing a 4" kanaflex intake, I removed the flame arrestor for the intake, and free flow exhaust. It should at least sound a a little better for next year. I guess it's time for a bilge pump too, LOL.


  2. #2
    carlosdelgado's Avatar
    Join Date
    Dec 2008
    Location
    West palm beach,FL
    Posts
    1,438
    +1
    85
    WOW, That's pretty bad. You're lucky your ski didn't sink for being on the water for 48 hours straight. Definitely I would install an R&d pump seal and do an alignment just to be sure. also won't hurt to replace your wear ring since it has 77 hours on it. Good luck!!!

  3. #3
    ProZadoX's Avatar
    Join Date
    Jan 2008
    Location
    Ottawa, Canada
    Posts
    351
    +1
    55
    Had my engine realigned at 25 hours.... there was ALOT of carbon dust at the bottom of the hull. I have a 2013. I thought mine was bad until I saw yours...

  4. #4
    saxwinder's Avatar
    Join Date
    Sep 2013
    Location
    Northern Ireland
    Posts
    107
    +1
    7
    Hi Jwall

    Check out my string about my 2012 GTR similar hours .. Dealer replaced ring and collar but said alignment ok
    Why would it wear prematurely if it were set up correctly.
    I still have doubts going into 2015 ...... as out of warranty now I may purchase the tools and do it myself.
    Good luck

    M

  5. #5

    Join Date
    Oct 2011
    Location
    Illinois
    Posts
    45
    yeah I purchased two brand new 2013 rxp x and both seals at the pump was like this, I have to get two new seals, I did find out about them when I was installing my SS wear ring

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Its not your motor that is out of alignment. Read the thread below. The 2012's seem to have this problem.


    http://www.greenhulk.net/forums/show...170389&page=31

  7. #7

    Join Date
    Apr 2012
    Location
    Troy, MO
    Posts
    496
    +1
    70
    Quote Originally Posted by troyheb View Post
    Its not your motor that is out of alignment. Read the thread below. The 2012's seem to have this problem.


    http://www.greenhulk.net/forums/show...170389&page=31

    I hope it is just the thru hull fitting alignment and not the pump shoe...That looks like it is a lot less easier than pump shoe alignment, lol. I am going to pick the alignment tool this week; I guess we will find out!

  8. #8

    Join Date
    Apr 2012
    Location
    Troy, MO
    Posts
    496
    +1
    70
    Engine was out of alignment according to the Seadoo engine alignment tool. 2 shims under both rear mounts got me where I needed to be. Ski is just about back together. Just have to wire up my bilge pump, and water test on the hose. Should be all set otherwise. Luckily I didn't have to pay someone to fix this damn thing....just a few hours labor and a few fiberglass splinters, lol.

  9. #9

    Join Date
    Apr 2012
    Location
    Troy, MO
    Posts
    496
    +1
    70
    Cleaned out the hull and got it all back together.


    Black billet bilge fitting.





  10. #10
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,532
    +1
    777
    In case someone comments...

    Those are the new (larger) "support ring" BRP are using to replace the older smaller diameter rings. Comes as a 2-piece "kit" (295 501 144).

    FYI: The larger diameter ring makes removing & installing the SC into the PTO a real PITA!!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2012 RXP-X 260 with R&D R3 reflash and Intake $11,000 only 11 hours
    By Boost Almighty in forum Sea Doo 4Tec Skis
    Replies: 3
    Last Post: 06-23-2014, 10:09 PM
  2. RXP-X 260 Carbon seal Replacement
    By waz480 in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-29-2014, 08:43 AM
  3. Factory 2012 RXP-X 260 speed and RPM
    By thomasdjames1 in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-24-2013, 08:49 PM
  4. Replies: 0
    Last Post: 02-21-2012, 10:23 PM
  5. Replies: 0
    Last Post: 02-21-2012, 10:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •