Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Xp 800 1996 mpem

    Good morning all
    I started a resurrection project on this old XP and am wondering if you guys can tell me if the MPEM in this unit is incorrect . Part number is 278-001-255 their seems to be so many versions out there i thought i would ask just to make sure one way or the other ?


    Any help would be greatly appreciated.


  2. #2
    The correct MPEM ends in 510 and the correct CDI ends in 0811.

  3. +1 by:


  4. #3
    Quote Originally Posted by Matt Braley View Post
    The correct MPEM ends in 510 and the correct CDI ends in 0811.

    Yeah i see this in the manual Matt but mine is nothing like that it is a single unit . Wonder why this is different as all the connections fit and when i connect up all the lights come on and then time out ?

  5. #4
    I'd like to see pics. The only other MPEM that is gonna plug into a 1996 XP and work would be the 897 from the 96 GSX/GTX(I think the XP800 from 95 is also a 510).

  6. #5
    Click image for larger version. 

Name:	IMG_1924.jpg 
Views:	57 
Size:	112.2 KB 
ID:	348789Click image for larger version. 

Name:	IMG_1925.jpg 
Views:	56 
Size:	94.1 KB 
ID:	348790Click image for larger version. 

Name:	IMG_1923.jpg 
Views:	58 
Size:	139.4 KB 
ID:	348791Click image for larger version. 

Name:	IMG_1926.jpg 
Views:	55 
Size:	141.9 KB 
ID:	348792 this is what i have Matt.

  7. #6
    Aha. Looks like a grey box from a 97-99SPX. That should work if it's good. Google the part # to make sure I'm right. Do you have the coded DESS key for it? The last two digits of your hull ID # are 96, right?

  8. #7
    Quote Originally Posted by Matt Braley View Post
    Aha. Looks like a grey box from a 97-99SPX. That should work if it's good. Google the part # to make sure I'm right. Do you have the coded DESS key for it? The last two digits of your hull ID # are 96, right?


    Yeah 96 Matt , Decided this morning to strip down again and check all the earths and connections . Put it all back together stuck on the dess and guess what beep beep and turns over whoopee.

  9. #8
    Very glad to hear it. Your gonna love that ski.

  10. #9
    Quote Originally Posted by Matt Braley View Post
    Very glad to hear it. Your gonna love that ski.

    Thanks for the help Matt , Got the old girl fired up this afternoon , sounds wicked can't wait to get on the water just got the drive to strip and rebuild.

  11. #10
    Matt quick question VTS and speedo gauges , are there any other numbers that will fit mine apart from the manual part numbers? Thought i would ask you first seen as you are pretty clued up.
    Struggling to find replacements.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Seadoo XP 800 Superstock
    By vxrpete8 in forum Sea Doo Classifieds
    Replies: 35
    Last Post: 07-18-2013, 10:13 PM
  2. 1996 Seadoo XP 800 Wont Start
    By 2blue in forum 2-Stroke Performance
    Replies: 16
    Last Post: 09-07-2011, 05:37 PM
  3. No spark, broken sensor pick up, fix 1996 XP/ 800
    By SideFX in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-04-2011, 05:34 PM
  4. 1996 Xp 800 starting issues
    By ianarm77 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-10-2009, 10:49 PM
  5. 1996 Seadoo XP 800 Superstock
    By vxrpete8 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 10-14-2007, 08:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •