Results 1 to 8 of 8
  1. #1
    Chrisf's Avatar
    Join Date
    Jan 2015
    Location
    Sydney
    Posts
    85
    +1
    1

    Rxp260rs , 30 hrs just purchased a few dramas

    Hi guys
    I'm new to this forum , but heard u are the best for knowledge of this type of ski
    just purchased this rxp260 rs three day ago with only. 30 hrs and had a few dramas I want to ask you about ,,, I took her out first morning with a mate on his ski , rode through no wash zone , and when was clear , I , pulled the throttle to see how it went ,, In normal mode ,,, it got to 45mph and the reves went up and down between6 and 8 felt like the boost was slipping ,, any way stopped told my mate something not right , we set the trim half tryed sport mode and went again ,, it was much better but , not perfect , as it's first time on ski I wasn't sure what to expect , so went to palm beach did some mild small wave stuff
    had swim and went back to boat ramp , 10 mins in sport pulled low oil pressure light , so took it back slow lee , rang previous owner , and he came and re serviced it , oil filter was squashed and one plug looked a bit corroded like it got a bit of water ,,, replaced plugs oil and filter took back out ,,,,
    same thing with slipping revs , between6-8 , but not in sport ,, ,, went for a nother ride out to waves , trying to feel it out ,, no oil lights all pretty good , acouple of little serges not in sport mode , , but then I did a sharp turn on a wave and turned it over , ,, put it back up the correct way ,,, started riding back ,,
    Low oil pressurelight came back on and kept revs low took it back to trailer

    what do you guys think,, slipping revs ??? 6-8
    i prob got water in it when I flipped it over , so needs a new service again , but what parts should I buy for this to make it strong ,, also are compressed oil filters common in this model , , my previous yamaha mechanic won't work on seadoo , so im a bit lost with tech advice
    Any help please guys


  2. #2
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Sounds like you had water in the oil still? That will cause the filter to collapse. Was the oil milky?
    Just changing the oil and filter will not remove all the moisture from the engine, you need to do a boil off and change the oil again.

    Just a tip, next time you think your going to roll the ski over, try to bail out, jump off. Instead of holding on and dragging the ski down with you. No need to hold on and drag the ski over and have the worry of water injestion. IMO just about the only way you can get these skis upside down is buy dragging them over.

  3. #3
    Chrisf's Avatar
    Join Date
    Jan 2015
    Location
    Sydney
    Posts
    85
    +1
    1
    Quote Originally Posted by Sayers View Post
    Sounds like you had water in the oil still? That will cause the filter to collapse. Was the oil milky?
    Just changing the oil and filter will not remove all the moisture from the engine, you need to do a boil off and change the oil again.

    Just a tip, next time you think your going to roll the ski over, try to bail out, jump off. Instead of holding on and dragging the ski down with you. No need to hold on and drag the ski over and have the worry of water injestion. IMO just about the only way you can get these skis upside down is buy dragging them over.
    Yeh your right , I tryed to stay on and bring it back but didn't happen,, but no the oil had a few bits of water not much , but that was from first ride, maybe got water in from waves on first go , would that pull a low oil pressure light , , the mechanic is coming sat to do full check over re service and check for any fault codes. Not sure if this one has collapsed , is there any mods I can do to get this more water tight from wave jumping or surf ,, , a better air box , pod or something ,,,, and any ideas on the revs in normal mode , -7-8full throttle after fresh service felt like it was sliping or serging a bit ,,, should I spend a bit on a computer upgrade , just spent 15500 , and want it to perform and be rely able

  4. #4
    Aussiepauly's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australa
    Posts
    898
    +1
    70
    You should not get water in the engine from wave jumping been doing it for years with no issue, has the intercooler been updated mate? Would be good to check with a Seadoo dealer to see if any warranty work has been done on it? I ride that area every week PM me if you have no luck and need some help.

  5. #5
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Does not sound right. The oil pressure will go off if there's enough water in it, oil level is low or filter water logged and collapsing. Do as Pauly said and see if it's had any previous issues and def check IC. Would be a good idea to check SC Slip.

    Dont mod anything until you sort the issues. Your WOT RPM should be at 8040.

  6. #6
    Chrisf's Avatar
    Join Date
    Jan 2015
    Location
    Sydney
    Posts
    85
    +1
    1
    Hi mate
    thanks for reply , the guy I bought from , had2 of the same model , his one was worked up , this was his wife's , he reckons he had his ic checked and tested and was fine but bought a top brand one and kept the other tested one , he said if something wrong with it he will give me the other inter cooler , guys ,, who are the best crew to look and work on this model , can u recommend a top mechanic that can get this thing running top notch for me , I'm in Hornsby , but anywhere in Sydney would work ,,, do u think it sounds like the clutch slipping in supercharger ,,, with the rev thing , I have a video if your interested and no one can help ,,, thanks heaps mate , much appreciated

  7. #7
    Aussiepauly's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australa
    Posts
    898
    +1
    70
    I live 10 minutes away from you mate PM me your number and I will call you to get sorted out
    it should be still under warranty if it's a 13' too

  8. #8
    Chrisf's Avatar
    Join Date
    Jan 2015
    Location
    Sydney
    Posts
    85
    +1
    1
    Thanks heaps mate

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just purchased RXP 215, few basic questions
    By TangoDown in forum Sea Doo Open Discussion
    Replies: 26
    Last Post: 12-08-2012, 10:40 PM
  2. 2006 FX HO (just purchased, few questions)
    By sbaird4000 in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-02-2012, 09:30 PM
  3. 94 SL 750 just purchased what should i check?
    By GameDemon in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-19-2007, 12:01 AM
  4. Just purchased a 1995 SLT 750.. Questions
    By daveo13 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-08-2006, 03:59 PM
  5. just purchased gp1200r
    By philip_gp1200r in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 04-02-2006, 05:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •