Results 1 to 6 of 6
  1. #1
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324

    Sick of those wire clips falling off?

    I have always had issues with the factory clips of various wire harnesses falling off. The ones that are stuck on with 2 sided tape. They are used on the under side of the hood on the MSX and SLTX models for sure that i Know of. I kept putting them back on using new 2 sided foam backed tape. I finally found something better. Its a little pricey but it works.

    First trick is to remove the old tape from the clip. I used a wire wheel chucked in my drill press. Peeled the tape off very easily. Then I used some solvent to clean off the left over adhesive.

    I bought this at the auto parts store. Its 7 bucks for a 5 foot roll, but its really strong stuff. Its similar to the tape used for the Go Pro sticky mounts.
    Click image for larger version. 

Name:	20150115_083249[1].jpg 
Views:	48 
Size:	66.3 KB 
ID:	349623

    Here is the new tape on the clip. This stuff sticks like mad and shouldn't fall off again.


    Click image for larger version. 

Name:	20150115_083305[1].jpg 
Views:	43 
Size:	60.5 KB 
ID:	349624
    Last edited by CrazyA; 01-15-2015 at 04:34 PM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Does modest heat soften the adhesive grip?

    As in a hot summer day, black hull in the sun. Or engine heat...

    If the stuff stays put even when very warm, this should be an excellent fix!

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    It should stay put. Its very strong stuff.

  4. #4
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Nice solution to a common problem. Every MSX I've seen have these clips fallen off...

    A dab of JBWeld on the clips... after removing/cleaning the old sticky stuff... has worked well for me. A little more permanent though.

    Hardest part is keeping the clips pressed against the hood and not moving while it dries.

    Cheers!

  5. #5
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    Just an FYI, I have had excellent results with quick dry JB weld. Use it all the time on these type clips.

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    This is the same stuff the factory uses. Plexus Methacrylate adhesive. Its the same goo used to bond the hull to the deck. This is a kit with a plunger to dispense the glue. You could do it without the mixing tip by squeezing some out on to cardboard and mixing it like you would epoxy.

    http://www.usplastic.com/catalog/ite...FQmqaQodlmAAFw

    If you just want the adhesive and nothing else....

    http://www.jamestowndistributors.com...FRAtaQodbTkAww

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva Grate falling off??
    By Kaybat in forum 4-Tec Performance
    Replies: 6
    Last Post: 02-03-2007, 07:49 AM
  2. Im sick of this, and im done with it..
    By waverider in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-24-2006, 11:09 AM
  3. Getting sick of waiting
    By JRW1484 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 05-16-2006, 10:19 AM
  4. SICK OF COLLEGE!!!!!!!!!!!
    By Cody Townsend in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 03-13-2006, 02:54 AM
  5. is this one of those scams??
    By sprchrgd89gt in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-25-2005, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •