Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    C-kit's Avatar
    Join Date
    Jan 2015
    Location
    Sydney nsw
    Posts
    109
    +1
    1

    06 Rxp 215 rebuild

    Rxp215 rebuild Fter I spun the lower bearing as the drive shft below failed and leaked all the oil out so ran dry and spin the lower end bearing damaged the block and crank unrepairble lucky I have had a spare block and my close mate had a almost new crank wich he gave me so after pulling the motor out and taking it apart I sent the head to be cleaned and tested now I'm waiting to order some stuff but I would like to hear what others have experienced so my rxp runs a c-kit super charger 60lbs injectors external cooler thru hull exhaust Riva rear air intake with prefilter seadoo centre ecu 8800rpm solas 14/19 prop been re pitched catch can opas block off open loop cooling I would just like to know my ski was dunning fine with my stock Pistons and rods do you think it's worth doin rods and forged Pistons for my ski or will the stock internals be fine for a c-kit thanks guys your help and suggestions will mean a lot cheers


  2. #2
    quiddo15's Avatar
    Join Date
    Aug 2012
    Location
    Sydney Australia
    Posts
    752
    +1
    109
    Lightened valves, titanium retainers and valve springs and you will
    be fine unless your pistons are fried then get forged pistons.

  3. #3
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    The stock pistons are forged.
    There are superior after market piston options, it just depends how much you want to spend.

  4. #4
    C-kit's Avatar
    Join Date
    Jan 2015
    Location
    Sydney nsw
    Posts
    109
    +1
    1
    Thanks for that now I can't wait to put it back together and take it out as I've never gps this ski before only owned it for a week and 2 outings before it spun the bearing so how you guys think I should run it in ?

  5. #5
    Aussiepauly's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australa
    Posts
    899
    +1
    70
    When all back together make sure you can see your AFRs when running in so you know if all good or not if you could log would be heaps better but I would find out details of that LC ecu if I were you, who knows what it is set up for??

  6. #6
    quiddo15's Avatar
    Join Date
    Aug 2012
    Location
    Sydney Australia
    Posts
    752
    +1
    109
    Seadoo centre ecu with 60lb injectors on my old PX was running lean wot Afr 13.3-13.5. As Paully said either log or set up an Afr gauge.

  7. #7
    C-kit's Avatar
    Join Date
    Jan 2015
    Location
    Sydney nsw
    Posts
    109
    +1
    1
    Will do I'll actually try get it in before I even take it out so what am I ment to see on the gauge at wot as I never really understood the afr thing but speaking of the ecu to be honest I think there's something up with it as before i spun the bearing 2 ppl had a look and said my oil had alot of fuel in it and looks like it was very thin and doubt it was lubricating much so before I take it out I will be checking my fuel set up as a mate of mine had the same issue when ridding his oz after every ride he'd need to service it oil and filter due too oil been fuely we later found the prob it had a BMW Z4 fuel pump in it replaced to oem pump problem solved

  8. #8
    quiddo15's Avatar
    Join Date
    Aug 2012
    Location
    Sydney Australia
    Posts
    752
    +1
    109
    Sounds like you were running rich. So with your Afr the lower the number = richer, higher the number = leaner
    So idle should be around 13-13.5 mid 13 Wot 11.9-12.3

  9. #9
    C-kit's Avatar
    Join Date
    Jan 2015
    Location
    Sydney nsw
    Posts
    109
    +1
    1
    Il thanks man that is the easiest way to explaine it cheers I get it so if I'm still running rich will a fpr help fix the problem and how cheers

  10. #10
    C-kit's Avatar
    Join Date
    Jan 2015
    Location
    Sydney nsw
    Posts
    109
    +1
    1
    Also wat mph are you doing quiddo I pressume there your mids on the bottom when you post damnnn sound like a quick one

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is a depth finder an add on option for a stock 06 rxp 215??
    By wotxxxsd in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 10-06-2013, 11:32 PM
  2. oil cooler on 06 rxp 215??
    By wotxxxsd in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-10-2013, 11:21 PM
  3. bearing failure on 06 rxp 215
    By wotxxxsd in forum 4-Tec Performance
    Replies: 10
    Last Post: 03-15-2013, 10:26 PM
  4. SuperCharger noise on 06 RXP 215. Louder than most??
    By Summer in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-07-2010, 07:39 PM
  5. 06 RXP SuperCharger rebuild kit needed ASAP!
    By mpourcho in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-03-2009, 08:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •