Results 1 to 8 of 8
  1. #1
    SOV's Avatar
    Join Date
    Nov 2014
    Location
    Cluj-Napoca, Romania
    Posts
    158
    +1
    2

    Athena problems...

    Hi everybody,

    just instaled my Athena ECU, finished the startup procedure with stage 1 map, but problems....!
    The engine starts very hard, I keep push the start button for seconds, after it starts the idle is not ok, after it stopsthe analogic gauge (2009 FX-SHO) freezes it does not go back to 0.


    Help...
    Sergiu


  2. #2
    RIVA CREW's Avatar
    Join Date
    Jul 2010
    Location
    Pompano Beach, FL
    Posts
    115
    +1
    29
    Hello Serqiu

    please contact our tech [email protected] looking at where you are located due to extreme cold and elevation we will need to customize your map to adjust to your application.

  3. #3
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    825
    +1
    57
    Is the old model? Called power connector ?

  4. #4
    SOV's Avatar
    Join Date
    Nov 2014
    Location
    Cluj-Napoca, Romania
    Posts
    158
    +1
    2
    No is the new one, Brian sent my problem to his engineer I hope he will resolve it.

  5. #5
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    825
    +1
    57
    Good luck with Athena....

  6. #6
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    Quote Originally Posted by Ale View Post
    Good luck with Athena....
    just because you had a bad experience with it, doesnt mean everyone else will.

  7. #7
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    825
    +1
    57
    Quote Originally Posted by Region8Ultra250X View Post
    Quote Originally Posted by Ale View Post
    Good luck with Athena....
    just because you had a bad experience with it, doesnt mean everyone else will.

    YES. it's true.

    I said good luck
    and not... you will blown your motor. you will have your idle at 1800/2000 rpm
    you will have to push start button for 3 second for start engine.

    in any case mine was previous model. no more for sale.

  8. #8
    SOV's Avatar
    Join Date
    Nov 2014
    Location
    Cluj-Napoca, Romania
    Posts
    158
    +1
    2
    Athena is Ok, I changed the map, I have stage 3 now, there was an injector problem, a riped o-ring.
    S.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ATHENA ECU problem
    By isa alnoaimi in forum 4-Tec Performance
    Replies: 11
    Last Post: 01-25-2015, 10:57 AM
  2. Head count from riva athena ecu problems
    By Sea Doo'nt Dan in forum 4-Tec Performance
    Replies: 23
    Last Post: 05-09-2014, 03:09 PM
  3. Yam FZR Riva stage 3+ with Athena Pro ecu problems
    By pearny in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 03-31-2014, 06:40 PM
  4. Problem of Athena ECU.
    By thomas loh in forum Sea Doo ECU Support
    Replies: 2
    Last Post: 01-13-2014, 11:51 AM
  5. Troubleshooting the Rotax Racing Stage I kit (was problems)
    By Jarrett in forum 4-Tec Performance
    Replies: 104
    Last Post: 10-22-2005, 08:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •