Results 1 to 6 of 6
  1. #1
    Chrisf's Avatar
    Join Date
    Jan 2015
    Location
    Sydney
    Posts
    85
    +1
    1

    13 rxpx 260new motor

    Hi guys
    thanks for ur help , and info on last post , turned out that the intercooler was leaking and had got water in the motor ,, it caused engine damage because and corrosion on valves , brp warranty a new create motor
    ,, just running in now , feels really nice , just wondered , someone told me to re build the supercharger as well , it has now new motor , intercooler , throttle body , mounts ,, but original supercharger ,,with35 hrs on it , when the ic let go , could it have damaged the charger , or do u think it should be fine , being , that the water would only hit the blades , or fan ,,, what do u guys recon ,, rebuild on first 10hrs service , or leave it for a while longer??
    thanks


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Your IC is down stream from the SC so very little to no chance of water damaging it. On my PX and TX, I found that the slip needed to be reset after about 20 hrs. As far as a rebuild, you should be good till around 100 hrs.

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    If it was mine I would definitely pull the SC and reset the slip and do a thorough inspection. If you feel any roughness while spinning the bearings it needs a complete rebuild. If you don't do this it will drive you nuts not knowing!

  4. #4
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    778
    While it is true the IC is downstream from SC, if enough water gets into motor (or long enough), it will find its way into the oil...then into the SC bearings = premature SC failure.

    Since everything else is new again, I would suggest changing the two bearings in the SC.

    Was the oil milky?
    Was this ridden in salt water?

  5. #5
    Chrisf's Avatar
    Join Date
    Jan 2015
    Location
    Sydney
    Posts
    85
    +1
    1
    Hi guys
    no the oil was not milky , but there was enough engine damage to warranty a new motor ,,, maybe re do the bearings,, I'm not sure , if it's 1000 bucks for charger rebuild maybe I should just to make sure all is new ,, ???are there any signs to look for about the charger failing , or what happens when they stuff out ??

  6. #6
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    its not pretty, the metal from the SC can fall down in to the oil pump

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 12-13 rxpx owners please chime in!
    By IM2FAST4U in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-04-2013, 06:43 PM
  2. Water strainer 2012-13 rxpx
    By IBADTON in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-20-2013, 06:02 AM
  3. Wedge on 13 Rxpx
    By IBADTON in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-15-2013, 10:32 PM
  4. Best rrfr for 13 rxpx
    By IBADTON in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-09-2013, 07:07 AM
  5. WTB stock 2012-13 rxpx 260 ecu
    By idoodou in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 03-13-2013, 03:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •