Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    04 RXP supercharger failure

    I have a 04 and had Roundy's install a NEW supercharger 1 week before they shut there door. About 6 hours later after lunch the motor would not start. Knowing that the superchager was new I removed the starter and it checked ok. Upon removing the SC I noticed that the gear had sheared off and the castle nut was missing and destroyed the fan. I removed the IC and only found some grease and a few small specks of aluminum powder in the back. This was easily cleaned up but still no castle nut. I ran an inspection camera down all of the cylinders and everything looks OK. At this time I am going to send the original SC to Jerry for rebuild. However as I haven't blown up the washers can I just reinstall Jerry's rebuild or do I have to do more work pryer to installing the SC.
    Thanks
    Static
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Missing castel nut.JPG 
Views:	116 
Size:	68.6 KB 
ID:	350386   Click image for larger version. 

Name:	Broken supercharger.JPG 
Views:	119 
Size:	47.8 KB 
ID:	350387  


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Wow, sorry for your bad luck. I would say your looking at more work than just the SC. Your gonna need to at least pull the PTO cover, and check the Flywheel for missing / damaged teeth, & inspect the oil pumps for small metal pieces/ Damage. Maybe even a timing chain, if something hit it at speed.

    Did the motor spin over after removing the SC?

    Have the valves ever been updated to the 06+ ones?

    How many hrs on the motor?

  3. #3
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    wow. The front nut came off and wiped out the blades too. There's no way you got away with just a SC failure. That engine is going to need to be pulled and inspected. Plan on a full rebuild in the PTO area

  4. #4
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    I would definitely be concerned about the metal in the oil pump. Time to put it on a stand and split the case. Anything less is asking for more trouble. You should also replace flywheel bolts and that POS timing chain while you are at it. Look for an '08-'10 German chain.

  5. #5
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    Quote Originally Posted by CCW View Post
    Look for an '08-'10 German chain.

    Look for a chain stamped IWIS

  6. #6
    The motor now has 200 hours and after the SC was removed everything turned over great. Using an inspection camera I can't find any chipped or missing teeth. However I will inspect the oil pump and other items pryer to starting. Thanks All

  7. #7
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Regardless, there are tons of metal shavings and a castle nut in that motor.

  8. #8
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    I'm glad they shut their doors......

  9. #9

    Join Date
    May 2012
    Location
    California
    Posts
    1,553
    +1
    130
    Quote Originally Posted by staticrider View Post
    The motor now has 200 hours and after the SC was removed everything turned over great. Using an inspection camera I can't find any chipped or missing teeth. However I will inspect the oil pump and other items pryer to starting. Thanks All
    don't ignore the great advise from this forum. Pull it and open it up or that motor will not see 10 more hours.

  10. +1 by:


  11. #10
    quiddo15's Avatar
    Join Date
    Aug 2012
    Location
    Sydney Australia
    Posts
    752
    +1
    109
    Hi mate, I bought my first ski back in 2007 which was a rxp 2007 model, the charger let go and I learnt the hard way, I put a new charger in and it lasted one ride, $5000 later and a rebuild. Don't risk it and take advice from others that have been there and done it all before. Best of luck mate!

  12. +1 by:


Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Supercharger failure coincidence or not?
    By H2HO in forum 4-Tec Performance
    Replies: 98
    Last Post: 07-21-2013, 11:53 AM
  2. FS 04 rxp supercharger complete
    By dan725 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 01-21-2010, 09:32 PM
  3. FS 04 rxp supercharger complete
    By dan725 in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 01-21-2010, 09:32 PM
  4. 04 RXP Supercharger to X Charger
    By monsoonmadness in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-02-2008, 09:09 PM
  5. Replies: 7
    Last Post: 10-14-2007, 04:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •