Results 1 to 2 of 2

Thread: Drive shaft??

  1. #1
    Chrisf's Avatar
    Join Date
    Jan 2015

    Drive shaft??

    Hi guys
    I just had a new warrenty motor put in my 13 rxpx260
    , have run in for 6 hrs , all going great till half hour into a ride today , stoped to talk to a mate , just touched reverse , heard a click , tryed to go foward , masive vibration on revs about 3.5-4, didn't push , sat on2.5 revs all the way back to beach , inspected prop , wear ring looks like new grove in it and drive shaft dose not look center in the hole coming out of hull , did the mechanic not fix the engine in properly , could it have come loose and out of alignment? , or do u reckon a bearing has gone , or something , could any one give me any advice ,, no water in ski no leaks , motor and super charger sound great ,, no fault modes came up , prop sounds rough , won't accelerate vibration ,, shaft out of alignment , some help please guys
    Many thanks

  2. #2
    Banned User
    Join Date
    Nov 2014
    Take it back for warranty again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. carbon seal, drive shaft seal??
    By CarFanatic in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-06-2006, 02:13 AM
  2. GP1200 drive shaft damper
    By hitman in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-01-2006, 10:23 PM
  3. Drive Shaft Plug Replacement
    By 1FastTrespiper in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-17-2006, 10:47 PM
  4. how to remove rear drive shaft coupler
    By chuck in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 02-20-2006, 08:37 AM
  5. aftermarket drive shaft question...
    By dewsy in forum 4-Tec Performance
    Replies: 4
    Last Post: 01-26-2006, 07:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts